summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-14 09:44:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-14 10:14:16 +0200
commit2a1829d61eb0cb53bbb578391d40d91d105fb3c9 (patch)
treebbb5bd251350b13eafbce447e8a7fbba7bc94c68
parentdev-python/iminuit: Bump to 2.6.1 (diff)
downloadgentoo-2a1829d6.tar.gz
gentoo-2a1829d6.tar.bz2
gentoo-2a1829d6.zip
dev-util/stripe-mock: Bump to 0.104.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.104.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index aa2eabd2b57c..68408cd4b45c 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1 +1,2 @@
DIST stripe-mock-0.103.0.tar.gz 567107 BLAKE2B 76dbc6bbb1d62ea68c30291fea894e563a426790c8928e7bc5a444eca8d48c8bcc23067459c1a249449af305a6809c70168918543087a1ef5e38cf7609421a7c SHA512 65ec61ccf94d1931389c4a16288dfac4d820a6fdf641cad1028347dfcb298aa4370d97d2dd4e468e17b8a702ce6b7611213b0707f1d5e37cd20aec46772e6a9c
+DIST stripe-mock-0.104.0.tar.gz 574936 BLAKE2B 681dcc2b02f5d4ca946024d1c049e499ce1c05c5a00653ca5a1af25325ce66b651e307df12ac0137fb38478332a8a04fb09ced39afa697a81a4afcc69a1cf314 SHA512 6d9c5fe5e5e83e8721ae441ae15e16594c690360a62934e825627add8acf6d58b0c4f52bd2c6d787c934fe0e974790b35b7c63d02f097647744549626b1708c5
diff --git a/dev-util/stripe-mock/stripe-mock-0.104.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.104.0.ebuild
new file mode 100644
index 000000000000..05a7220e34b0
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.104.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D}$(get_golibdir_gopath)" || die
+}