summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-01 08:22:14 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-01 09:32:03 +0100
commit2a1a16e182de3e23be87bae90500e0274f2edbd5 (patch)
tree59c07d2df45e630dbb889a2cd1838028f1c3090c
parentdev-python/ruamel-yaml: Bump to 0.17.17 (diff)
downloadgentoo-2a1a16e1.tar.gz
gentoo-2a1a16e1.tar.bz2
gentoo-2a1a16e1.zip
dev-python/jaraco-context: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jaraco-context/Manifest1
-rw-r--r--dev-python/jaraco-context/jaraco-context-4.1.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/jaraco-context/Manifest b/dev-python/jaraco-context/Manifest
index a1dc974d4ca1..cc7a4c6734ab 100644
--- a/dev-python/jaraco-context/Manifest
+++ b/dev-python/jaraco-context/Manifest
@@ -1 +1,2 @@
DIST jaraco.context-4.0.0.tar.gz 11257 BLAKE2B 38faeb6036ebd2fc6cea9f29dc7fbd89b0ea60819e280e36c8c4f0f90e9ba2552524bfc0f3fc16601cd43276d19e166d9de4107ced885f88dea11efbe0a79913 SHA512 ec76e03d3d5a2148dd49159b303ee278501b9744d3e4d096d6aca516658fb04da020d1cbb1c8eb3dcb58097266e0419883d23e4064c295ced3846540177e57ee
+DIST jaraco.context-4.1.1.tar.gz 7615 BLAKE2B 5734da1c55420c45520aea57398e66a3d880a555c76650bcaf3427911a7814be92f4a879219c8ccf3c808fdf00d3a77b76e68a93ef3fdad4ea50550188118317 SHA512 e01d3bd7b4eb712d00aba3fc40a78a5484141fcacf5bc772287a35ac81eca4c9744963679daadf6a170cf2ec26234243e602c89f71833fe84175ac39fb401453
diff --git a/dev-python/jaraco-context/jaraco-context-4.1.1.ebuild b/dev-python/jaraco-context/jaraco-context-4.1.1.ebuild
new file mode 100644
index 000000000000..74789d5377ad
--- /dev/null
+++ b/dev-python/jaraco-context/jaraco-context-4.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Context managers by jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.context"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest