summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-06-29 21:47:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-06-29 21:53:16 +0200
commit2a200ab7f01daf00e1b5f6a5d00ab85b787b77b5 (patch)
tree0811623d28242cc4ae63eeb3a19e8f461849c9f8
parentkde-frameworks/kio: filewidgets: update location text after selected (diff)
downloadgentoo-2a200ab7.tar.gz
gentoo-2a200ab7.tar.bz2
gentoo-2a200ab7.zip
kde-frameworks/kio: KRecentDocuments: Improve indentation
...in recentlyused.xbel Upstream commit 0dd0e96c10f634974c63f85c2068e44019c27591 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=456046 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kio/files/kio-5.95.0-fix-recent-files-in-gtk-apps.patch25
-rw-r--r--kde-frameworks/kio/kio-5.95.0-r1.ebuild5
2 files changed, 29 insertions, 1 deletions
diff --git a/kde-frameworks/kio/files/kio-5.95.0-fix-recent-files-in-gtk-apps.patch b/kde-frameworks/kio/files/kio-5.95.0-fix-recent-files-in-gtk-apps.patch
new file mode 100644
index 000000000000..524fdc871fc8
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.95.0-fix-recent-files-in-gtk-apps.patch
@@ -0,0 +1,25 @@
+From 0dd0e96c10f634974c63f85c2068e44019c27591 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?M=C3=A9ven=20Car?= <meven@kdemail.net>
+Date: Wed, 29 Jun 2022 10:14:50 +0200
+Subject: [PATCH] KRecentDocuments: Improve indentation in recentlyused.xbel
+
+BUG: 456046
+---
+ src/core/krecentdocument.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/core/krecentdocument.cpp b/src/core/krecentdocument.cpp
+index 23fcbbd09..87d276b06 100644
+--- a/src/core/krecentdocument.cpp
++++ b/src/core/krecentdocument.cpp
+@@ -270,6 +270,7 @@ static bool addToXbel(const QUrl &url, const QString &desktopEntryName, KRecentD
+
+ if (!foundExisting) {
+ // must create new bookmark tag
++ output.writeCharacters(QStringLiteral(" "));
+ output.writeStartElement(bookmarkTag);
+
+ output.writeAttribute(hrefAttribute, newUrl);
+--
+GitLab
+
diff --git a/kde-frameworks/kio/kio-5.95.0-r1.ebuild b/kde-frameworks/kio/kio-5.95.0-r1.ebuild
index 8b7697b65a88..85dc54c90eef 100644
--- a/kde-frameworks/kio/kio-5.95.0-r1.ebuild
+++ b/kde-frameworks/kio/kio-5.95.0-r1.ebuild
@@ -70,7 +70,10 @@ DEPEND="${RDEPEND}
"
PDEPEND=">=kde-frameworks/kded-${PVCUT}:5"
-PATCHES=( "${FILESDIR}/${P}-filewidgets-update-filename-after-rename.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-filewidgets-update-filename-after-rename.patch"
+ "${FILESDIR}/${P}-fix-recent-files-in-gtk-apps.patch"
+)
src_configure() {
local mycmakeargs=(