summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-30 19:39:27 +0100
committerSam James <sam@gentoo.org>2021-06-30 19:39:27 +0100
commit2a33652d6b14521269121d2a611568a0487d083b (patch)
tree31257dfce8d0f3d8af3e9f42f10969b2ae541016
parentnet-irc/ninja: add missing libcrypt dependency (diff)
downloadgentoo-2a33652d.tar.gz
gentoo-2a33652d.tar.bz2
gentoo-2a33652d.zip
net-irc/muh: add missing libcrypt dependency
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-irc/muh/muh-2.2a-r2.ebuild (renamed from net-irc/muh/muh-2.2a-r1.ebuild)11
1 files changed, 7 insertions, 4 deletions
diff --git a/net-irc/muh/muh-2.2a-r1.ebuild b/net-irc/muh/muh-2.2a-r2.ebuild
index 4a90c58d0c86..620f26da6f48 100644
--- a/net-irc/muh/muh-2.2a-r1.ebuild
+++ b/net-irc/muh/muh-2.2a-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Persistent IRC bouncer"
HOMEPAGE="http://mind.riot.org/muh/"
@@ -12,8 +12,13 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~mips ppc ~sparc x86"
IUSE="ipv6"
+RDEPEND="virtual/libcrypt:="
+DEPEND="${RDEPEND}"
+
src_configure() {
- econf --datadir=/usr/share/muh $(use_enable ipv6)
+ econf \
+ --datadir=/usr/share/muh \
+ $(use_enable ipv6)
}
src_install() {
@@ -22,10 +27,8 @@ src_install() {
}
pkg_postinst() {
- elog
elog "You'll need to configure muh before running it."
elog "Put your config in ~/.muh/muhrc"
elog "A sample config is /usr/share/muh/muhrc"
elog "For more information, see the documentation."
- elog
}