summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-19 01:34:54 +0100
committerSam James <sam@gentoo.org>2021-08-19 01:39:08 +0100
commit2a5c0c46e3051cc42c3299eae20fb77ce6d10e7e (patch)
tree6e3a23aeb5e2226d699cf651d5cc6312e50656d8
parentmedia-gfx/tuxpaint: fix libsdl[joystick] dependency (diff)
downloadgentoo-2a5c0c46.tar.gz
gentoo-2a5c0c46.tar.bz2
gentoo-2a5c0c46.zip
games-action/rrootage: respect CC/CXX, fix libsdl[joystick] dependency
Closes: https://bugs.gentoo.org/808636 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-action/rrootage/files/rrootage-0.23a-gcc41.patch8
-rw-r--r--games-action/rrootage/rrootage-0.23a-r2.ebuild (renamed from games-action/rrootage/rrootage-0.23a-r1.ebuild)12
2 files changed, 11 insertions, 9 deletions
diff --git a/games-action/rrootage/files/rrootage-0.23a-gcc41.patch b/games-action/rrootage/files/rrootage-0.23a-gcc41.patch
index 1e6e50e683fd..00926f9b75dc 100644
--- a/games-action/rrootage/files/rrootage-0.23a-gcc41.patch
+++ b/games-action/rrootage/files/rrootage-0.23a-gcc41.patch
@@ -1,5 +1,5 @@
---- src/foecommand.h.old 2006-04-21 23:26:03.000000000 +0200
-+++ src/foecommand.h 2006-04-21 23:26:26.000000000 +0200
+--- a/foecommand.h
++++ b/foecommand.h
@@ -39,10 +39,10 @@
virtual void doChangeDirection(double d);
@@ -15,8 +15,8 @@
private:
struct foe *foe;
---- src/screen.c.old 2006-04-21 23:50:01.000000000 +0200
-+++ src/screen.c 2006-04-21 23:50:30.000000000 +0200
+--- a/screen.c
++++ b/screen.c
@@ -73,7 +73,7 @@
void loadGLTexture(char *fileName, GLuint *texture) {
SDL_Surface *surface;
diff --git a/games-action/rrootage/rrootage-0.23a-r1.ebuild b/games-action/rrootage/rrootage-0.23a-r2.ebuild
index 7fbee7b1a767..0defc88d5323 100644
--- a/games-action/rrootage/rrootage-0.23a-r1.ebuild
+++ b/games-action/rrootage/rrootage-0.23a-r2.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
MY_PN="rRootage"
MY_P="${MY_PN}-${PV}"
@@ -9,11 +11,11 @@ DESCRIPTION="Abstract shooter - defeat auto-created huge battleships"
HOMEPAGE="http://www.asahi-net.or.jp/~cs8k-cyu/windows/rr_e.html
http://rrootage.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_PN}/src
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="
>=dev-libs/libbulletml-0.0.3
@@ -21,9 +23,7 @@ DEPEND="
media-libs/sdl-mixer[vorbis]
virtual/glu
virtual/opengl"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${MY_PN}/src
+RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}"-gcc41.patch
@@ -50,6 +50,8 @@ src_prepare() {
src_compile() {
emake \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
MORE_CFLAGS="-DLINUX ${CFLAGS}" \
MORE_CXXFLAGS="-DLINUX ${CXXFLAGS}"
}