summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-27 07:39:44 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-27 08:19:37 +0100
commit2a73f6d187bb5e2b28938bec541fc642171310a5 (patch)
tree51294f118eb125a5879e83caddbe2ea8c7653d4b
parentdev-python/ipython: Bump to 7.30.0 (diff)
downloadgentoo-2a73f6d187bb5e2b28938bec541fc642171310a5.tar.gz
gentoo-2a73f6d187bb5e2b28938bec541fc642171310a5.tar.bz2
gentoo-2a73f6d187bb5e2b28938bec541fc642171310a5.zip
dev-python/prompt_toolkit: Bump to 3.0.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/prompt_toolkit/Manifest1
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.23.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index dbdb020f0a93..e3a9ea117537 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1 +1,2 @@
DIST prompt_toolkit-3.0.22.tar.gz 3041540 BLAKE2B 30afe5e4d4267d6264bfe7fbc179d311d13490971dd461ad6a4461640611fa1f7d55f2ed0b3c3ba534e3b52f9456ca69d2f6f14baba511aa7806866cf40edc57 SHA512 859f5df00792fa9332c9dc6a7b12e01048aa6b2cd88c35fe5e3521defee69ef9122e4f7f415711538b22171e2519ce846062270f319f12ac4390406036d715fb
+DIST prompt_toolkit-3.0.23.tar.gz 3041820 BLAKE2B 99835732024771caf5feef478d904547b8e305e521be87898d861902445ee27ded67962b9ec9905dbfc6bcbaeb8da8d71b52ab1b901cf3758e2c1af1c6f61103 SHA512 9b57f50c7e42bc99697b2b10ce30eb50289eafd71ecc79d64d0afc6a1565dc08d33f7e4ab06903f94dcb1808efa74535dac64426b5816e1f4f034007583d04ba
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.23.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.23.ebuild
new file mode 100644
index 000000000000..94196a1224c8
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.23.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest