summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-09-07 14:37:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-07 14:39:19 +0200
commit2a7eaccc299a0ddace71e92f79c9916fee4a70ec (patch)
tree02fa6e2099f67a686f3d2711144637ed068e4114
parentapp-arch/cabextract: add bdepend (diff)
downloadgentoo-2a7eaccc.tar.gz
gentoo-2a7eaccc.tar.bz2
gentoo-2a7eaccc.zip
net-libs/libssh: add 0.10.3
Changelog: Fixed possible infinite loop in known hosts checking Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-libs/libssh/Manifest1
-rw-r--r--net-libs/libssh/libssh-0.10.3.ebuild135
2 files changed, 136 insertions, 0 deletions
diff --git a/net-libs/libssh/Manifest b/net-libs/libssh/Manifest
index e75dd2adba4e..2b2dfe6d4024 100644
--- a/net-libs/libssh/Manifest
+++ b/net-libs/libssh/Manifest
@@ -1,3 +1,4 @@
DIST libssh-0.10.1.tar.xz 553808 BLAKE2B 1e0a648153122619e473481484af70b9c388e75a6586a7b5ea605fede4a592f2f1ae2978c19762ac396d3dff2a3dd03451ee293c9fbd4f861a1bb5668e2489b7 SHA512 d56b2809527d4f3c1d88881b8f7a7cd49321df8abe4fde011dfe7323e7552641b36a607f3b1b37c26703adae01d0176fc3d71c6c207598aaae5ebdf10237742e
DIST libssh-0.10.2.tar.xz 554240 BLAKE2B 5732ed9709735ced62c6a1c0fc32f4c35d26bf26fd8a086ce145f7f6c679468c146a1c1a8f85035dc73971f60bd59b0a784e5fe0afc2575de947b386a4cef804 SHA512 8855ebb9ea97e6ad03dec800e0885381c5397a04f5578f0b79b82e49458766f7b6c394713c4fbdc8ff6bb8d3b4c3b8b4f7b797f39ddbc95caf205ee6d89d3278
+DIST libssh-0.10.3.tar.xz 554928 BLAKE2B 5bb1feecf77ec038b89cec1058d0c401d2f3ecca6975ee098dc9eb4d3b981b807d54291f915f8f7e236dc06ac864289f99d92ea1d6983afda1044a690c8207e6 SHA512 dfc992a4d16bf3de6ed01b1d0d73e061f61acf6785b2c81a722154219a286fc2b8952dec0e842bcbc14ce2734078161a820d44091f01851c8538f8f381655253
DIST libssh-0.9.6.tar.xz 1053056 BLAKE2B e8565279a430786b8877386a26700a39386e908546a209815b135a2bf4ef42c37b9890dc29cda9ce6c8bfe3f3bae4942097dc794302aec767d106a45c44b811d SHA512 4040ec4af937e95be2e41313ef6d4db60b46b8d4dea10c09402398127c1d1ca8843392d207088aeee3c7ef631c6ae7b66861327dcebf78ed3af0723777619fd1
diff --git a/net-libs/libssh/libssh-0.10.3.ebuild b/net-libs/libssh/libssh-0.10.3.ebuild
new file mode 100644
index 000000000000..c8592e03bb83
--- /dev/null
+++ b/net-libs/libssh/libssh-0.10.3.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Access a working SSH implementation by means of a library"
+HOMEPAGE="https://www.libssh.org/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
+else
+ SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+IUSE="debug doc examples gcrypt gssapi mbedtls pcap server +sftp static-libs test zlib"
+# Maintainer: check IUSE-defaults at DefineOptions.cmake
+
+REQUIRED_USE="?? ( gcrypt mbedtls )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !gcrypt? (
+ !mbedtls? (
+ >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
+ )
+ )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ mbedtls? ( net-libs/mbedtls:=[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}]
+ elibc_musl? ( sys-libs/argp-standalone )
+ )
+"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+DOCS=( AUTHORS CHANGELOG README )
+
+src_prepare() {
+ cmake_src_prepare
+
+ # just install the examples, do not compile them
+ cmake_comment_add_subdirectory examples
+
+ sed -e "/^check_include_file.*HAVE_VALGRIND_VALGRIND_H/s/^/#DONT /" \
+ -i ConfigureChecks.cmake || die
+
+ if use test; then
+ local skip_tests=(
+ # keyfile torture test is currently broken
+ -e "/torture_keyfiles/d"
+
+ # Tries to expand ~ which fails w/ portage homedir
+ # (torture_path_expand_tilde_unix and torture_config_make_absolute_no_sshdir)
+ -e "/torture_misc/d"
+ -e "/torture_config/d"
+ )
+
+ # Disable tests that take too long (bug #677006)
+ if use sparc; then
+ skip_tests+=(
+ -e "/torture_threads_pki_rsa/d"
+ -e "/torture_pki_dsa/d"
+ )
+ fi
+
+ if (( ${#skip_tests[@]} )) ; then
+ sed -i "${skip_tests[@]}" tests/unittests/CMakeLists.txt || die
+ fi
+
+ if use elibc_musl; then
+ sed -e "/SOLARIS/d" \
+ -i tests/CMakeLists.txt || die
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DWITH_NACL=OFF
+ -DWITH_STACK_PROTECTOR=OFF
+ -DWITH_STACK_PROTECTOR_STRONG=OFF
+ -DWITH_DEBUG_CALLTRACE=$(usex debug)
+ -DWITH_DEBUG_CRYPTO=$(usex debug)
+ -DWITH_GCRYPT=$(usex gcrypt)
+ -DWITH_GSSAPI=$(usex gssapi)
+ -DWITH_MBEDTLS=$(usex mbedtls)
+ -DWITH_PCAP=$(usex pcap)
+ -DWITH_SERVER=$(usex server)
+ -DWITH_SFTP=$(usex sftp)
+ -DBUILD_STATIC_LIB=$(usex static-libs)
+ # TODO: try enabling {CLIENT,SERVER}_TESTING
+ -DUNIT_TESTING=$(usex test)
+ -DWITH_ZLIB=$(usex zlib)
+ )
+
+ multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
+
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+ multilib_is_native_abi && use doc && cmake_src_compile docs
+}
+
+multilib_src_install() {
+ cmake_src_install
+ multilib_is_native_abi && use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+
+ use static-libs && dolib.a src/libssh.a
+
+ # compatibility symlink until all consumers have been updated
+ # to no longer use libssh_threads.so
+ dosym libssh.so /usr/$(get_libdir)/libssh_threads.so
+}
+
+multilib_src_install_all() {
+ use mbedtls && DOCS+=( README.mbedtls )
+ einstalldocs
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,cpp}
+ fi
+}