summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-02-26 13:19:38 -0600
committerBen Kohler <bkohler@gentoo.org>2021-02-26 13:19:51 -0600
commit2aa05cb2e17a1c9a6131a6e95955be999446f263 (patch)
tree3fdcd6e655082de232548824894f73a6977abe61
parentdev-tcltk/tclreadline: fix 64 bit location (diff)
downloadgentoo-2aa05cb2.tar.gz
gentoo-2aa05cb2.tar.bz2
gentoo-2aa05cb2.zip
app-admin/xkcdpass: fix up manpage a bit
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--app-admin/xkcdpass/files/xkcdpass-manpage-fix.patch89
-rw-r--r--app-admin/xkcdpass/xkcdpass-1.17.6-r1.ebuild40
2 files changed, 129 insertions, 0 deletions
diff --git a/app-admin/xkcdpass/files/xkcdpass-manpage-fix.patch b/app-admin/xkcdpass/files/xkcdpass-manpage-fix.patch
new file mode 100644
index 000000000000..a4d9e3464ce8
--- /dev/null
+++ b/app-admin/xkcdpass/files/xkcdpass-manpage-fix.patch
@@ -0,0 +1,89 @@
+diff -ur xkcdpass-1.17.6/xkcdpass.1 xkcdpass-1.17.6.new/xkcdpass.1
+--- xkcdpass-1.17.6/xkcdpass.1 2021-02-26 12:58:59.441739487 -0600
++++ xkcdpass-1.17.6.new/xkcdpass.1 2021-02-26 13:11:21.195161091 -0600
+@@ -1,40 +1,14 @@
+-.SH xkcdpass
+-.SS generate memorable, secure multiword passphrases
+-.TP
+-.B Author
+-|authorname| |authoremail|
+-.RS
+-.RE
+-.TP
+-.B Date
+-2015\-01\-17
+-.RS
+-.RE
+-.TP
+-.B Copyright
+-BSD license, attribution and disclaimer required, no endorsement
+-allowed.
+-.RS
+-.RE
+-.TP
+-.B Manual section
+-1
+-.RS
+-.RE
+-.TP
+-.B Manual group
+-Admin
+-.RS
+-.RE
+-.SS SYNOPSIS
+-.PP
+-\f[B]xkcdpass\f[] [ option ...
+-]
+-.PD 0
+-.P
+-.PD
+-\f[B]xkcdpass\f[] \f[B]\-\-help\f[]
+-.SS DESCRIPTION
++.TH xkcdpass 1
++.SH NAME
++xkcdpass - generate memorable, secure multiword passphrases
++.SH SYNOPSIS
++.PP
++.B xkcdpass
++[ options ]
++.br
++.B xkcdpass
++--help
++.SH DESCRIPTION
+ .PP
+ A flexible and scriptable password generator which generates strong
+ passphrases, inspired by XKCD 936:
+@@ -45,7 +19,7 @@
+ >\ correct\ horse\ battery\ staple
+ \f[]
+ .fi
+-.SS OPTIONS
++.SH OPTIONS
+ .PP
+ \f[B]\-\-help\f[]
+ .RS
+@@ -156,22 +130,14 @@
+ \f[]
+ .fi
+ .RE
+-.SS HISTORY
++.SH HISTORY
+ .PP
+ The \f[B]xkcdpass\f[] command invokes the Python program
+ \f[C]xkcd_password.py\f[].
+ .PP
+-The inspiration for the program\[aq]s purpose is the XKCD 936_ “Password
++The inspiration for the program\[aq]s purpose is the XKCD 936 “Password
+ Strength” cartoon.
+ .PP
+ The application is maintained by Steven Tobin <<steven@steventob.in>>.
+ .PP
+ This manual page was written by |authorname| |authoremail|.
+-.SS
+-.RS
+-.PP
+-Local variables: mode: rst coding: utf\-8 time\-stamp\-format:
+-"%:y\-%02m\-%02d" time\-stamp\-start: "^:Date:[ ]+" time\-stamp\-end:
+-"$" time\-stamp\-line\-limit: 20 End: vim: filetype=rst
+-fileencoding=utf\-8 :
+-.RE
diff --git a/app-admin/xkcdpass/xkcdpass-1.17.6-r1.ebuild b/app-admin/xkcdpass/xkcdpass-1.17.6-r1.ebuild
new file mode 100644
index 000000000000..ee512ef60329
--- /dev/null
+++ b/app-admin/xkcdpass/xkcdpass-1.17.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Password generator inspired by XKCD 936"
+HOMEPAGE="https://github.com/redacted/XKCD-password-generator"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD CC-BY-3.0
+ l10n_de? ( GPL-3 )
+ l10n_it? ( CC-BY-SA-3.0 )
+ l10n_no? ( CC-BY-4.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="l10n_de l10n_en l10n_es l10n_fi l10n_fr l10n_it l10n_no l10n_pt"
+
+PATCHES=( "${FILESDIR}"/xkcdpass-manpage-fix.patch )
+
+src_prepare() {
+ default
+
+ use l10n_de || rm ${PN}/static/ger-anlx
+ use l10n_en || rm ${PN}/static/{eff-short,eff-special,legacy}
+ use l10n_es || rm ${PN}/static/spa-mich
+ use l10n_fi || rm ${PN}/static/fin-kotus
+ use l10n_fr || rm ${PN}/static/fr-*
+ use l10n_it || rm ${PN}/static/ita-wiki
+ use l10n_no || rm ${PN}/static/nor-nb
+ use l10n_pt || rm ${PN}/static/pt-*
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}