summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-07 09:05:46 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-07 09:10:29 +0200
commit2acf3a14236e928d6a3c3a3323bd825cd4d593ea (patch)
tree4c70e923b6f7044a1bb30669f706628c2fe14ef6
parentdev-python/urdf_parser_py: Remove old (diff)
downloadgentoo-2acf3a14236e928d6a3c3a3323bd825cd4d593ea.tar.gz
gentoo-2acf3a14236e928d6a3c3a3323bd825cd4d593ea.tar.bz2
gentoo-2acf3a14236e928d6a3c3a3323bd825cd4d593ea.zip
dev-ros/rospack: simplify on top of recent ros-catkin.eclass changes.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-ros/rospack/files/multipy.patch40
-rw-r--r--dev-ros/rospack/rospack-2.4.1.ebuild10
-rw-r--r--dev-ros/rospack/rospack-9999.ebuild10
3 files changed, 0 insertions, 60 deletions
diff --git a/dev-ros/rospack/files/multipy.patch b/dev-ros/rospack/files/multipy.patch
deleted file mode 100644
index 8350cc0a8da2..000000000000
--- a/dev-ros/rospack/files/multipy.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Install separate libraries linking to different python implementations.
-
-Index: rospack-2.4.1/CMakeLists.txt
-===================================================================
---- rospack-2.4.1.orig/CMakeLists.txt
-+++ rospack-2.4.1/CMakeLists.txt
-@@ -23,28 +23,28 @@ endif()
-
- include_directories(include ${TinyXML2_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
-
--add_library(rospack
-+add_library(rospack-py${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}
- src/rospack.cpp
- ${backcompat_source}
- src/rospack_cmdline.cpp
- src/utils.cpp
- )
--target_link_libraries(rospack ${TinyXML2_LIBRARIES} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
-+target_link_libraries(rospack-py${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} ${TinyXML2_LIBRARIES} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
-
- add_executable(rospackexe src/rospack_main.cpp)
- # Set the name, and make it a "global" executable
- set_target_properties(rospackexe PROPERTIES
- OUTPUT_NAME rospack
- RUNTIME_OUTPUT_DIRECTORY ${CATKIN_DEVEL_PREFIX}/bin)
--target_link_libraries(rospackexe rospack ${Boost_LIBRARIES})
-+target_link_libraries(rospackexe rospack-py${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} ${Boost_LIBRARIES})
- add_executable(rosstackexe src/rosstack_main.cpp)
--target_link_libraries(rosstackexe rospack ${Boost_LIBRARIES})
-+target_link_libraries(rosstackexe rospack-py${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} ${Boost_LIBRARIES})
- # Set the name, and make it a "global" executable
- set_target_properties(rosstackexe PROPERTIES
- OUTPUT_NAME rosstack
- RUNTIME_OUTPUT_DIRECTORY ${CATKIN_DEVEL_PREFIX}/bin)
-
--install(TARGETS rospack rospackexe rosstackexe
-+install(TARGETS rospack-py${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} rospackexe rosstackexe
- ARCHIVE DESTINATION ${CATKIN_PACKAGE_LIB_DESTINATION}
- LIBRARY DESTINATION ${CATKIN_PACKAGE_LIB_DESTINATION}
- RUNTIME DESTINATION ${CATKIN_GLOBAL_BIN_DESTINATION})
diff --git a/dev-ros/rospack/rospack-2.4.1.ebuild b/dev-ros/rospack/rospack-2.4.1.ebuild
index 7d49abfd9591..18b9f633ad3f 100644
--- a/dev-ros/rospack/rospack-2.4.1.ebuild
+++ b/dev-ros/rospack/rospack-2.4.1.ebuild
@@ -5,7 +5,6 @@ EAPI=5
ROS_REPO_URI="https://github.com/ros/rospack"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit ros-catkin
@@ -29,13 +28,4 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/gentoo.patch"
- "${FILESDIR}/multipy.patch"
)
-
-src_install() {
- ros-catkin_src_install
- # Assume greatest alphabetically is what we want as default implementation
- for i in "${ED}"/usr/$(get_libdir)/librospack*.so ; do
- dosym $(basename "${i}") /usr/$(get_libdir)/librospack.so
- done
-}
diff --git a/dev-ros/rospack/rospack-9999.ebuild b/dev-ros/rospack/rospack-9999.ebuild
index 7d49abfd9591..18b9f633ad3f 100644
--- a/dev-ros/rospack/rospack-9999.ebuild
+++ b/dev-ros/rospack/rospack-9999.ebuild
@@ -5,7 +5,6 @@ EAPI=5
ROS_REPO_URI="https://github.com/ros/rospack"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit ros-catkin
@@ -29,13 +28,4 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/gentoo.patch"
- "${FILESDIR}/multipy.patch"
)
-
-src_install() {
- ros-catkin_src_install
- # Assume greatest alphabetically is what we want as default implementation
- for i in "${ED}"/usr/$(get_libdir)/librospack*.so ; do
- dosym $(basename "${i}") /usr/$(get_libdir)/librospack.so
- done
-}