summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2023-02-19 16:21:20 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-02-27 18:46:53 +0200
commit2ad7471df4b05d94ce984de1b54f6f2f8304ff34 (patch)
tree1df71834091a71d72ff36e3e801795da65bcd028
parentdev-lang/rakudo: update EAPI 7 -> 8 (diff)
downloadgentoo-2ad7471d.tar.gz
gentoo-2ad7471d.tar.bz2
gentoo-2ad7471d.zip
sci-libs/vtk: build against CUDA 12
Closes: https://bugs.gentoo.org/894646 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/29664 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sci-libs/vtk/files/vtk-9.2.5-Fix-compilation-error-with-CUDA-12.patch21
-rw-r--r--sci-libs/vtk/vtk-9.2.5.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/vtk/files/vtk-9.2.5-Fix-compilation-error-with-CUDA-12.patch b/sci-libs/vtk/files/vtk-9.2.5-Fix-compilation-error-with-CUDA-12.patch
new file mode 100644
index 000000000000..9b8583fa61e2
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-9.2.5-Fix-compilation-error-with-CUDA-12.patch
@@ -0,0 +1,21 @@
+https://894646.bugs.gentoo.org/attachment.cgi?id=851914
+https://gitlab.kitware.com/vtk/vtk-m/-/merge_requests/2972/diffs
+
+From be96ea7d85fefcad876729377c1b73a295d1c732 Mon Sep 17 00:00:00 2001
+From: "Luke A. Guest" <laguest@archeia.com>
+Date: Thu, 16 Feb 2023 16:57:32 +0000
+Subject: [PATCH] Fix compilation error with CUDA 12.
+
+--- a/ThirdParty/vtkm/vtkvtkm/vtk-m/vtkm/exec/cuda/internal/ExecutionPolicy.h
++++ b/ThirdParty/vtkm/vtkvtkm/vtk-m/vtkm/exec/cuda/internal/ExecutionPolicy.h
+@@ -17,6 +17,7 @@
+ #include <vtkm/exec/cuda/internal/ThrustPatches.h>
+ VTKM_THIRDPARTY_PRE_INCLUDE
+ #include <thrust/execution_policy.h>
++#include <thrust/sort.h>
+ #include <thrust/system/cuda/execution_policy.h>
+ #include <thrust/system/cuda/memory.h>
+ VTKM_THIRDPARTY_POST_INCLUDE
+--
+2.39.1
+
diff --git a/sci-libs/vtk/vtk-9.2.5.ebuild b/sci-libs/vtk/vtk-9.2.5.ebuild
index 88721c38e704..eb117e951095 100644
--- a/sci-libs/vtk/vtk-9.2.5.ebuild
+++ b/sci-libs/vtk/vtk-9.2.5.ebuild
@@ -163,6 +163,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-9.2.2-link-with-glut-library-for-freeglut.patch
"${FILESDIR}"/${PN}-9.2.5-Add-include-cstdint-to-compile-with-gcc-13.patch
"${FILESDIR}"/${PN}-9.2.5-Add-include-cstdint-for-gcc-13.patch
+ "${FILESDIR}"/${PN}-9.2.5-Fix-compilation-error-with-CUDA-12.patch
)
DOCS=( CONTRIBUTING.md README.md )