summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-27 10:29:08 +0100
committerSam James <sam@gentoo.org>2023-05-27 10:29:11 +0100
commit2ae8e8fa196911e674390e6d1107cbec7f7c92c7 (patch)
treecfc49402ba330b31186d683ee595b49bc3988daf
parentapp-portage/prefix-toolkit: cleanup remnants (diff)
downloadgentoo-2ae8e8fa196911e674390e6d1107cbec7f7c92c7.tar.gz
gentoo-2ae8e8fa196911e674390e6d1107cbec7f7c92c7.tar.bz2
gentoo-2ae8e8fa196911e674390e6d1107cbec7f7c92c7.zip
app-text/qpdf: add 11.4.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/qpdf/Manifest2
-rw-r--r--app-text/qpdf/qpdf-11.4.0.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
index d2b68fab5f83..3b5d4151594e 100644
--- a/app-text/qpdf/Manifest
+++ b/app-text/qpdf/Manifest
@@ -4,3 +4,5 @@ DIST qpdf-11.2.0-doc.zip 7066797 BLAKE2B c30d3d768bc0d49d751a4c15d3dd5c72040a0b9
DIST qpdf-11.2.0.tar.gz 18450040 BLAKE2B e42aeaf911f9d912eb0abfbebbe737ab9927c337b46cf96f9286ec3ce562c887c23922695435da90f04e8149e16de204563832e1fd742ffe8665d123efc6c699 SHA512 6e28be1fc9cb6aa124229301a43a565ef80ffffab9bacaeabebfbf4ced17c9702a432330a995be390a8fe3d69ac1773ca72b6c24e40f1bf74a71219e02dbac70
DIST qpdf-11.3.0-doc.zip 6781831 BLAKE2B 0b494ff62e197a60d82a170a27816676dc465d1a53f4201955dd8063980c09df31ddfd206e6625c5cfdc1994026651a2fe8278b1b73a4bc13de4b0a30c2cbbb4 SHA512 c652ba56b4c740af74889579732e18336910b09edbe125783ad4b6b1556df0cc3f32e2514c9bb611aebe233a8708d58701ed466ba6b4f3ff652ed56527650b9c
DIST qpdf-11.3.0.tar.gz 18732977 BLAKE2B 80dd2a96f3b82b9e530f26c72cd24cd3b111e2e1cbe821b12af13807e8d54fbc7f5632130f5cbd03df1b7c70de3c94a7e889d4ea4f1a3670a28f726364564b16 SHA512 1c8a0b62d50efb4c09885f36244048797dea44f28917aefe0266e2b158858ea19d477bbc445abbd3b7180a3de56d6a819ff44275cdc0979827effba9739b53d2
+DIST qpdf-11.4.0-doc.zip 6854262 BLAKE2B 58b55287fbef37beae452803db409e163f3fcf4fb32e2b154cd815452192550217e63771a5be39a43e6425f558a1064bc2257c24c90b842029eb373dfd865223 SHA512 25aab31b8481034bba876411eab2034375a9ffed97666c221b211400b1a7e60cfc11b5237406733058fbbbd2412baad7aa6029ad4303d0ddd879f6d7aff3b2b0
+DIST qpdf-11.4.0.tar.gz 18643945 BLAKE2B cde1c4db4c51733fe71a7e46fc271817825b5a56ce81053edf0f886eabdf13bce55308dd36ebf9b5067dcf173f371135bbc651253a7df214b9863c2b62cdde8f SHA512 6f31a37a9a52752c89d319e0d29d8e6c1e4885ca494de47a65f9374cdb5672497ab93f754481300c8e6c68fc2874860997b778dc05386b6f3e6a5a70a3f9f754
diff --git a/app-text/qpdf/qpdf-11.4.0.ebuild b/app-text/qpdf/qpdf-11.4.0.ebuild
new file mode 100644
index 000000000000..596bff408664
--- /dev/null
+++ b/app-text/qpdf/qpdf-11.4.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake bash-completion-r1
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="https://qpdf.sourceforge.net/"
+# TODO: verify-sig
+SRC_URI="https://github.com/qpdf/qpdf/releases/download/v${PV}/${P}.tar.gz"
+SRC_URI+=" doc? ( https://github.com/qpdf/qpdf/releases/download/v${PV}/${P}-doc.zip )"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+# Subslot for libqpdf soname version (just represent via major version)
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples gnutls ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ media-libs/libjpeg-turbo:=
+ sys-libs/zlib
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ app-text/ghostscript-gpl[tiff(+)]
+ media-libs/tiff
+ sys-apps/diffutils
+ )
+"
+BDEPEND="
+ dev-lang/perl
+ doc? ( app-arch/unzip )
+"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+ # Keep an eye on https://qpdf.readthedocs.io/en/stable/packaging.html.
+ local mycmakeargs=(
+ -DINSTALL_EXAMPLES=$(usex examples)
+
+ # Breaks install with USE=-doc in 11.0.0?
+ #-DINSTALL_MANUAL=ON
+ )
+
+ if use ssl ; then
+ local crypto_provider=$(usex gnutls GNUTLS OPENSSL)
+ local crypto_provider_lowercase=${crypto_provider,,}
+ mycmakeargs+=(
+ -DDEFAULT_CRYPTO=${crypto_provider_lowercase}
+ -DREQUIRE_CRYPTO_${crypto_provider}=ON
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ if use doc ; then
+ mv "${WORKDIR}"/${P}-doc "${BUILD_DIR}"/manual/doc-dist || die
+ fi
+
+ cmake_src_install
+
+ # Completions
+ dobashcomp completions/bash/qpdf
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_qpdf
+}