summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-03-01 02:29:02 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-03-01 21:39:11 +0100
commit2b31f686b80091668d7d394c739f6e9c4e467dcc (patch)
treeb49a56dffa0fce74a9d37f9a8a27cf9ae0812ec5
parentacct-group/supervisor: new group for app-admin/supervisor (diff)
downloadgentoo-2b31f686.tar.gz
gentoo-2b31f686.tar.bz2
gentoo-2b31f686.zip
app-admin/supervisor: bump to 4.1.0, add Py3.8, improvements
* Switch supervisor group to GLEP 81. * Rely on distutils_enable_* functions. * meld3 is now bundled with supervisor. * Stop requiring mock for tests (not needed for Python 3). Closes: https://bugs.gentoo.org/702732 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--app-admin/supervisor/Manifest1
-rw-r--r--app-admin/supervisor/supervisor-4.1.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index 1c7ee90462b7..9f8a8819e14e 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -1 +1,2 @@
DIST supervisor-4.0.4.tar.gz 437708 BLAKE2B 211726da07ce31c00da0d6edba57942d78ee5d2757927b22afe569364c29aaf55375d4895b381f06071bc6b6c39a926ca2073e8fcb8e0ea9673a89aafd08b346 SHA512 22a38f759b0584310f5e16acbfc7b0c4cc59f3206fbfaf6295bd40a826d50ad02c8b0093821362c5038dd987a6599879d82dcefe948a2eda702b89e9f92e471e
+DIST supervisor-4.1.0.tar.gz 459020 BLAKE2B 0c4bdc2c89f54c08ad536b43852941f1aadb0173013e0f73337302f500b779023bfa0fcf8cc3ace4968cfc724998a08ea5a63680e290051d13c7cd8ac788dd24 SHA512 1ae343293707ebf33d0a0c0bda2c6cc78278e12737940a79e51b2365e7a20b07d9f5e50134ed2abbf8e7af1ebd8f1746002a159cde1cfc35e83fda0a77dae9c5
diff --git a/app-admin/supervisor/supervisor-4.1.0.ebuild b/app-admin/supervisor/supervisor-4.1.0.ebuild
new file mode 100644
index 000000000000..66bc0c1f5828
--- /dev/null
+++ b/app-admin/supervisor/supervisor-4.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 systemd
+
+MY_PV="${PV/_beta/b}"
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="acct-group/supervisor"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newinitd "${FILESDIR}/init.d-r2" supervisord
+ newconfd "${FILESDIR}/conf.d-r1" supervisord
+ dodoc supervisor/skel/sample.conf
+ keepdir /etc/supervisord.d
+ insinto /etc
+ doins "${FILESDIR}/supervisord.conf"
+ keepdir /var/log/supervisor
+ systemd_dounit "${FILESDIR}/supervisord.service"
+}
+
+pkg_preinst() {
+ fowners :supervisor /var/log/supervisor
+ fperms 750 /var/log/supervisor
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You may install your configuration files in ${EROOT}/etc/supervisord.d"
+ elog "For config examples, see ${EROOT}/usr/share/doc/${PF}/sample.conf.bz2"
+ elog ""
+ elog "By default, only members of the supervisor group can run supervisorctl."
+ fi
+}