summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-25 20:23:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-25 20:23:21 +0300
commit2b7d1ca5d776e6333b735120148025ef8bccba4a (patch)
tree9ae0eee5a5c2e9b066b9b2523193c1ff70510035
parentdev-python/plette: add 2.0.2 (diff)
downloadgentoo-2b7d1ca5d776e6333b735120148025ef8bccba4a.tar.gz
gentoo-2b7d1ca5d776e6333b735120148025ef8bccba4a.tar.bz2
gentoo-2b7d1ca5d776e6333b735120148025ef8bccba4a.zip
dev-python/Faker: add 24.14.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/Faker/Faker-24.14.0.ebuild43
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-24.14.0.ebuild b/dev-python/Faker/Faker-24.14.0.ebuild
new file mode 100644
index 000000000000..6677ad70e7c8
--- /dev/null
+++ b/dev-python/Faker/Faker-24.14.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ local EPYTEST_DESELECT=(
+ tests/providers/test_job.py::TestCsCZ::test_job
+ )
+ epytest
+}
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 2a40692c1898..f328105144da 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1,2 +1,3 @@
DIST Faker-24.11.0.tar.gz 1726502 BLAKE2B 52429b5b0db4e1fd55d2a4b30ed007417f37e36fbec8d4fe43dea316920d85877668f4e66107011fef5874b74b25c1465fcfc0990ee3f40810df064622bb5373 SHA512 d5ee8c7c048d113c37b13608406d96966745ab46b095fcb30c9107a27a7af909c9d4d6bf9c7bb478ad7d0604b3cb6b33b93b0ba9e1a321c20870d651f57617a5
+DIST Faker-24.14.0.tar.gz 1732995 BLAKE2B 809773a97b417827db72172c3ba68ccf814974771abfde1609087369667b2889c7c118c2b1f4d250c2d67252c33e384d1bc0048f7bb7c5ae790a62486650b4aa SHA512 d767d4e7c7bb96b137f82f51c20dd211b1d94c79384bdcf81f73591e68457e51f884103c6a0569264712bad334774e8f0a909e94d028b9c2ec741211ea69e77b
DIST Faker-24.8.0.tar.gz 1725365 BLAKE2B b2646766b993d946bf7965133b7484408370a2e8bed9091b713ffd427d545bb708027066b6787a78cd675659b4d342ac86c9f611aecfb7df3d0565a8066925f0 SHA512 d8fe7e411052bec485b40540317c88ff5aeae8a32ef2e53214816b190d4730c9f5af9157ac2c66aba5fbc887e995d0238f71deefdcf67300e49586c7995b60ff