summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2017-01-05 21:40:41 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2017-01-07 13:35:09 -0800
commit2b7df23399d7b274f8029aedf7df00ee69243c13 (patch)
tree430afc0f19acb297b3e78559610ce1e4b27c8202
parentsys-process/acct: initd implement checkpath, #603606 (diff)
downloadgentoo-2b7df23399d7b274f8029aedf7df00ee69243c13.tar.gz
gentoo-2b7df23399d7b274f8029aedf7df00ee69243c13.tar.bz2
gentoo-2b7df23399d7b274f8029aedf7df00ee69243c13.zip
net-misc/openssh: Use pkg_pretend() to detect earlier unsupported features
Package-Manager: portage-2.3.0 (cherry picked from commit 4862b9b82b4722272da4639999f757d733d67335) Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--net-misc/openssh/openssh-7.3_p1-r7.ebuild4
-rw-r--r--net-misc/openssh/openssh-7.3_p1-r8.ebuild4
-rw-r--r--net-misc/openssh/openssh-7.4_p1.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/net-misc/openssh/openssh-7.3_p1-r7.ebuild b/net-misc/openssh/openssh-7.3_p1-r7.ebuild
index 0f8d7742cd7c..6c9b32426990 100644
--- a/net-misc/openssh/openssh-7.3_p1-r7.ebuild
+++ b/net-misc/openssh/openssh-7.3_p1-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -76,7 +76,7 @@ RDEPEND="${RDEPEND}
S=${WORKDIR}/${PARCH}
-pkg_setup() {
+pkg_pretend() {
# this sucks, but i'd rather have people unable to `emerge -u openssh`
# than not be able to log in to their server any more
maybe_fail() { [[ -z ${!2} ]] && echo "$1" ; }
diff --git a/net-misc/openssh/openssh-7.3_p1-r8.ebuild b/net-misc/openssh/openssh-7.3_p1-r8.ebuild
index f886839d5865..164f4e1375b8 100644
--- a/net-misc/openssh/openssh-7.3_p1-r8.ebuild
+++ b/net-misc/openssh/openssh-7.3_p1-r8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -71,7 +71,7 @@ RDEPEND="${RDEPEND}
S=${WORKDIR}/${PARCH}
-pkg_setup() {
+pkg_pretend() {
# this sucks, but i'd rather have people unable to `emerge -u openssh`
# than not be able to log in to their server any more
maybe_fail() { [[ -z ${!2} ]] && echo "$1" ; }
diff --git a/net-misc/openssh/openssh-7.4_p1.ebuild b/net-misc/openssh/openssh-7.4_p1.ebuild
index 110f1bfb4700..4f6efad0cad3 100644
--- a/net-misc/openssh/openssh-7.4_p1.ebuild
+++ b/net-misc/openssh/openssh-7.4_p1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -70,7 +70,7 @@ RDEPEND="${RDEPEND}
S=${WORKDIR}/${PARCH}
-pkg_setup() {
+pkg_pretend() {
# this sucks, but i'd rather have people unable to `emerge -u openssh`
# than not be able to log in to their server any more
maybe_fail() { [[ -z ${!2} ]] && echo "$1" ; }