summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-08-27 01:07:54 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-08-27 01:08:27 -0700
commit2b8df15c030224073db4b37f5e74e4c9bce8fa66 (patch)
tree2758605cc4499279f81da8d15363a0d579e88a4a
parentsys-fs/zfs: backport nls useflag to 0.8.4 (diff)
downloadgentoo-2b8df15c.tar.gz
gentoo-2b8df15c.tar.bz2
gentoo-2b8df15c.zip
sys-fs/zfs: backport minimal useflag to 0.8.4
Closes: https://bugs.gentoo.org/701522 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--sys-fs/zfs/zfs-0.8.4-r2.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/sys-fs/zfs/zfs-0.8.4-r2.ebuild b/sys-fs/zfs/zfs-0.8.4-r2.ebuild
index 50fa48c210c6..6b30ef219ee4 100644
--- a/sys-fs/zfs/zfs-0.8.4-r2.ebuild
+++ b/sys-fs/zfs/zfs-0.8.4-r2.ebuild
@@ -21,10 +21,9 @@ fi
LICENSE="BSD-2 CDDL MIT"
SLOT="0"
-IUSE="custom-cflags debug kernel-builtin libressl nls python +rootfs test-suite static-libs"
+IUSE="custom-cflags debug kernel-builtin libressl minimal nls python +rootfs test-suite static-libs"
DEPEND="
- ${PYTHON_DEPS}
net-libs/libtirpc[static-libs?]
sys-apps/util-linux[static-libs?]
sys-libs/zlib[static-libs(+)?]
@@ -32,6 +31,7 @@ DEPEND="
virtual/libudev[static-libs(-)?]
libressl? ( dev-libs/libressl:0=[static-libs?] )
!libressl? ( dev-libs/openssl:0=[static-libs?] )
+ !minimal? ( ${PYTHON_DEPS} )
python? (
virtual/python-cffi[${PYTHON_USEDEP}]
)
@@ -65,7 +65,11 @@ RDEPEND="${DEPEND}
)
"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="
+ !minimal? ( ${PYTHON_REQUIRED_USE} )
+ python? ( !minimal )
+ test-suite? ( !minimal )
+"
RESTRICT="test"
@@ -119,7 +123,7 @@ src_prepare() {
src_configure() {
use custom-cflags || strip-flags
- python_setup
+ use minimal || python_setup
local myconf=(
--bindir="${EPREFIX}/bin"
@@ -133,13 +137,13 @@ src_configure() {
--with-linux="${KV_DIR}"
--with-linux-obj="${KV_OUT_DIR}"
--with-udevdir="$(get_udevdir)"
- --with-python="${EPYTHON}"
--with-systemdunitdir="$(systemd_get_systemunitdir)"
--with-systemdpresetdir="${EPREFIX}/lib/systemd/system-preset"
$(use_enable debug)
$(use_enable nls)
$(use_enable python pyzfs)
$(use_enable static-libs static)
+ $(usex minimal --without-python --with-python="${EPYTHON}")
)
econf "${myconf[@]}"
@@ -178,7 +182,7 @@ src_install() {
fi
# enforce best available python implementation
- python_fix_shebang "${ED}/bin"
+ use minimal || python_fix_shebang "${ED}/bin"
}
pkg_postinst() {