summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-07 23:32:40 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-08 00:27:21 +0100
commit2b9ad6463ec9c7f83e6bc13283db6b4d1b8e83ea (patch)
treedaa28cf21278337bb14e18e6f20ff559301389ba
parentdev-python/rq: Bump to 1.10.1 (diff)
downloadgentoo-2b9ad6463ec9c7f83e6bc13283db6b4d1b8e83ea.tar.gz
gentoo-2b9ad6463ec9c7f83e6bc13283db6b4d1b8e83ea.tar.bz2
gentoo-2b9ad6463ec9c7f83e6bc13283db6b4d1b8e83ea.zip
dev-python/pytest-testinfra: Bump to 6.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-testinfra/Manifest1
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index 14286a38f523..272d76610acf 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1 +1,2 @@
DIST pytest-testinfra-6.4.0.tar.gz 77516 BLAKE2B 2baf5940e8736cbe78d8017a82b3a8fdb6df95b89acccd49ecd354447b7ea88079f48211e0acea46a0d8702b67609fe6f85f730c66e781a99d8a92b52b3c99b9 SHA512 acd2c7f9daeb391815a32c972a3542c0d643a716f3cffcb66f4203435ebac789333edb91c83d2778ae8da93b676b245fd47821bca9218faa3e7b50e6764087f4
+DIST pytest-testinfra-6.5.0.tar.gz 77177 BLAKE2B 98a8f10f7cf62f204c117d295496a7dfa4de476f5cde457af6f5bc71b22e12e9f02b4893adc6b0d1be11915ed652f628c2574fd44750c82c690e3d8326e29c4c SHA512 f7fcf8facafc0d99b06f55f4241c39b610ff7648b0049c584a75b46944b522b957c98c353f147d74bc8a72f677a179380c456b0868f9dae9af514a9c95d55b13
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild
new file mode 100644
index 000000000000..c336646d0373
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="https://github.com/pytest-dev/pytest-testinfra"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+# Ansible is called via its CLI
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible
+ app-admin/salt[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}