summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-08-24 12:43:38 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-08-24 12:43:52 +0200
commit2ba6809cc12db0ea2a17f8508b66cb6a3bd8f555 (patch)
treeba68eff032ca24edfad1588a5a2d03ea795d2246
parentnet-nntp/nzbget: fix build with OpenSSL 3, bump to EAPI 8 (diff)
downloadgentoo-2ba6809c.tar.gz
gentoo-2ba6809c.tar.bz2
gentoo-2ba6809c.zip
sys-fs/genimage: Add live ebuild
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--sys-fs/genimage/genimage-15.ebuild10
-rw-r--r--sys-fs/genimage/genimage-9999.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/sys-fs/genimage/genimage-15.ebuild b/sys-fs/genimage/genimage-15.ebuild
index 20da57056618..4a0e18372d87 100644
--- a/sys-fs/genimage/genimage-15.ebuild
+++ b/sys-fs/genimage/genimage-15.ebuild
@@ -5,13 +5,19 @@ EAPI=8
inherit autotools optfeature
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pengutronix/genimage.git"
+else
+ SRC_URI="https://github.com/pengutronix/genimage/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
DESCRIPTION="Tool to generate multiple filesystem and flash images from a tree"
HOMEPAGE="https://github.com/pengutronix/genimage"
-SRC_URI="https://github.com/pengutronix/genimage/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/sys-fs/genimage/genimage-9999.ebuild b/sys-fs/genimage/genimage-9999.ebuild
new file mode 100644
index 000000000000..4a0e18372d87
--- /dev/null
+++ b/sys-fs/genimage/genimage-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools optfeature
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pengutronix/genimage.git"
+else
+ SRC_URI="https://github.com/pengutronix/genimage/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Tool to generate multiple filesystem and flash images from a tree"
+HOMEPAGE="https://github.com/pengutronix/genimage"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/confuse:="
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( sys-apps/fakeroot )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_postinst() {
+ optfeature "cpio support" app-arch/cpio
+ optfeature "tar support" app-arch/tar
+ optfeature "qemu support" app-emulation/qemu
+ optfeature "dosfstools support" sys-fs/dosfstools
+ optfeature "cramfs support" sys-fs/cramfs
+ optfeature "genext2fs support" sys-fs/genext2fs
+ optfeature "jffs, ubifs and ubinize support" sys-fs/mtd-utils
+ optfeature "squashfs support" sys-fs/squashfs-tools
+}