summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-09 08:56:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-09 09:26:08 +0200
commit2bd24d0a105d3a0736a18ed901fbc69ea4e62dbc (patch)
tree97a4840be02892060d57beaf6569634f809a7991
parentdev-util/stripe-mock: Bump to 0.109.0 (diff)
downloadgentoo-2bd24d0a105d3a0736a18ed901fbc69ea4e62dbc.tar.gz
gentoo-2bd24d0a105d3a0736a18ed901fbc69ea4e62dbc.tar.bz2
gentoo-2bd24d0a105d3a0736a18ed901fbc69ea4e62dbc.zip
dev-python/botocore: Bump to 1.20.108
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.108.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 219c313e4080..df94b30f007c 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,4 +2,5 @@ DIST botocore-1.20.104.tar.gz 7883624 BLAKE2B 4fb4c6abff5a2c3d3e19b11576e723f15a
DIST botocore-1.20.105.tar.gz 7883335 BLAKE2B b48347e304ea54b56a37faae8bcbe9c127118b5bfadc71ffff3f6914b57f4d819faaadfc25834e49c9523f073f639823db4046bcbd9b5b72ee1df4c2ad198338 SHA512 72267620e4ecb7e4e4fa446b8f5c0b42d2e0af372f9e8bcfea123e5d8a6f4638102d57a9eb9f3c6f2358c6c2b36e727552c0b350b07f95a79292fb3c2cf4dd99
DIST botocore-1.20.106.tar.gz 7885164 BLAKE2B 3fa8b860a40a0915f6a59912fdee7b9e55fa88170da747d4d87464a5b44d6cbd5ce83cec383a7a1f41ec9a203d43a8cc006c7fc0005bfcf2869d66aa9f333b14 SHA512 135d789e2d5975697840dc4aca759b2d07d70d58efed7356a3323feb54faa2b8a339a48a3ac931270e335bc730eb8cc5e87f6fc2f9e3aebc452aab331ca49261
DIST botocore-1.20.107.tar.gz 7893209 BLAKE2B 4e4882efef667ae91bb3e42a84748609390ef637d0a72a0b8b9dbab83a55cac9117553a0ef34bd38af98493d0972fd6178b322207c71914068eb3c634debaae9 SHA512 09c7a4bc4fab922aa7dbe94fcc0da6a462dbd90bdd51e8612431e5a790b46c56eab3b436048572a4a14c6ed2417ddca8efa52474d28fbe32558550c44b3fe0dd
+DIST botocore-1.20.108.tar.gz 7897833 BLAKE2B 3b4ee27640dbfce1c9923137ef21500649454eba8e1a5b569fb0d949253e619852b61344ff86c769e2f2314a089047fe9590a685982491b21f4f7feb0a33b220 SHA512 a394fa8fc686d07ad5e1a25f0403d4adf53aa6af565696c4bd5aab58ee8f739b761f4c8058263a05b028175d1256ab87fa7fae3035cee605f236749939cc0eab
DIST botocore-1.20.97.tar.gz 7846552 BLAKE2B da0355cc229ba8a0632f67866bf06b27d7b257184b53670e5dc183c6b5a1f4d3a34145de0a3f04abd2adc08de3f0775e3c7e0dbecae729acb5bc05c7ce9acaf2 SHA512 7411d5de8ecf0c42c0142ded036189dcf378cd16f761071beb5bc2a2c240eabb0c4a8c669ce89a5b4e798a0aae92f0e67755627c2a84df77fc2e9557265a4e3b
diff --git a/dev-python/botocore/botocore-1.20.108.ebuild b/dev-python/botocore/botocore-1.20.108.ebuild
new file mode 100644
index 000000000000..30e0988848ad
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.108.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}