summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-05-03 18:20:05 +0200
committerPacho Ramos <pacho@gentoo.org>2022-05-03 18:20:24 +0200
commit2bdc40aacedb418a158b612aefd4157a46f02c3a (patch)
tree3f8e9d1b3d636eb89e35ddca79294b6964cded3f
parentmedia-libs/mesa: Add USE flag to enable proprietary codecs (diff)
downloadgentoo-2bdc40aa.tar.gz
gentoo-2bdc40aa.tar.bz2
gentoo-2bdc40aa.zip
sys-apps/xdg-desktop-portal-gnome: Add new portal with GNOME dependencies
Bug: 816135 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/metadata.xml8
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.1.ebuild46
3 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gnome/Manifest b/sys-apps/xdg-desktop-portal-gnome/Manifest
new file mode 100644
index 000000000000..a8084aba273f
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/Manifest
@@ -0,0 +1 @@
+DIST xdg-desktop-portal-gnome-42.1.tar.xz 117932 BLAKE2B c0c6dc7e4efbfda8996d63c191228ebf867e3fe11a0ae031b5bfd4298a33ab3b9cb9d9cecc36c1b41eeb33c54bd3bca17149e641c1131f0be7dcb2dbdf42eda8 SHA512 6843fd10e7e70f3d09c2a9b1397288f553fb44bcae30e7992790fddbc92d6c5cc966c27b7f294e2de1a139d3893c009f1480855d66c873a13861f3fe4abecee7
diff --git a/sys-apps/xdg-desktop-portal-gnome/metadata.xml b/sys-apps/xdg-desktop-portal-gnome/metadata.xml
new file mode 100644
index 000000000000..f453528b934f
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.1.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.1.ebuild
new file mode 100644
index 000000000000..f4088f66bdb1
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-42.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+MY_PV="${PV//_pre*}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="wayland X"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ gui-libs/libadwaita:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.7
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}