summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-28 19:39:40 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-28 19:55:22 +0200
commit2c225ccf4290ca7ff62969fe624bbf623f509638 (patch)
tree24520fdbcd316ce1c850b0f835d6ccc02b4ff5d5
parentvirtual/emacs: Virtual for slot 26. (diff)
downloadgentoo-2c225ccf.tar.gz
gentoo-2c225ccf.tar.bz2
gentoo-2c225ccf.zip
dev-libs/dietlibc: Fix compilation (#644116 by Mike Hiretsky)
Package-Manager: Portage-2.3.38, Repoman-2.3.9
-rw-r--r--dev-libs/dietlibc/dietlibc-0.34_pre20140729-r1.ebuild13
-rw-r--r--dev-libs/dietlibc/files/dietlibc-0.34_pre20140729-dyn-lib.patch22
2 files changed, 31 insertions, 4 deletions
diff --git a/dev-libs/dietlibc/dietlibc-0.34_pre20140729-r1.ebuild b/dev-libs/dietlibc/dietlibc-0.34_pre20140729-r1.ebuild
index ab312bfd8734..ac5939a008db 100644
--- a/dev-libs/dietlibc/dietlibc-0.34_pre20140729-r1.ebuild
+++ b/dev-libs/dietlibc/dietlibc-0.34_pre20140729-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils flag-o-matic toolchain-funcs
+EAPI=6
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="A libc optimized for small size"
HOMEPAGE="http://www.fefe.de/dietlibc/"
@@ -16,11 +16,16 @@ IUSE=""
DEPEND=""
RDEPEND=""
-DIETHOME=/usr/diet
+DIETHOME="/usr/diet"
-S=${WORKDIR}/dietlibc
+S="${WORKDIR}/dietlibc"
src_prepare() {
+ default
+
+ # use __DYN_LIB instead of __PIC__ in i386 socketcalls, bug #644116
+ eapply "${FILESDIR}"/${P}-dyn-lib.patch
+
# Replace sparc64 related C[XX]FLAGS (see bug #45716)
use sparc && replace-sparc64-flags
diff --git a/dev-libs/dietlibc/files/dietlibc-0.34_pre20140729-dyn-lib.patch b/dev-libs/dietlibc/files/dietlibc-0.34_pre20140729-dyn-lib.patch
new file mode 100644
index 000000000000..fe3fcb072f63
--- /dev/null
+++ b/dev-libs/dietlibc/files/dietlibc-0.34_pre20140729-dyn-lib.patch
@@ -0,0 +1,22 @@
+From 843c667c1b516c0764840c6e4d41188f9c96a415 Mon Sep 17 00:00:00 2001
+From: leitner <leitner>
+Date: Mon, 4 Sep 2017 21:59:50 +0000
+Subject: [PATCH] use __DYN_LIB instead of __PIC__ in i386 socketcalls
+
+---
+ i386/syscalls.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/i386/syscalls.h b/i386/syscalls.h
+index 11d6f1d5..14ac517b 100644
+--- a/i386/syscalls.h
++++ b/i386/syscalls.h
+@@ -416,7 +416,7 @@ sym: \
+ .Lend##sym: ; \
+ .size sym,.Lend##sym-sym
+
+-#ifndef __PIC__
++#ifndef __DYN_LIB
+ #define __socketcall(name,NAME) \
+ .text; \
+ .type name,@function; \