summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-11-14 16:05:09 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 16:05:09 +0100
commit2c2f573a7425dbe0d399d1d8b03dd219db2797f6 (patch)
tree4ef7431e1309d46f78aabdab5439fddf48a7a6d6
parentmedia-sound/timidity-freepats: Port to EAPI 7 (diff)
downloadgentoo-2c2f573a7425dbe0d399d1d8b03dd219db2797f6.tar.gz
gentoo-2c2f573a7425dbe0d399d1d8b03dd219db2797f6.tar.bz2
gentoo-2c2f573a7425dbe0d399d1d8b03dd219db2797f6.zip
media-sound/gqradio: Port to EAPI 7
* Fix broken .desktop file Closes: https://bugs.gentoo.org/740360 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--media-sound/gqradio/files/gqradio-1.9.2-desktop-QA.patch20
-rw-r--r--media-sound/gqradio/files/gqradio-1.9.2-underlinking.patch4
-rw-r--r--media-sound/gqradio/gqradio-1.9.2.ebuild19
3 files changed, 34 insertions, 9 deletions
diff --git a/media-sound/gqradio/files/gqradio-1.9.2-desktop-QA.patch b/media-sound/gqradio/files/gqradio-1.9.2-desktop-QA.patch
new file mode 100644
index 000000000000..b9ec631f59fb
--- /dev/null
+++ b/media-sound/gqradio/files/gqradio-1.9.2-desktop-QA.patch
@@ -0,0 +1,20 @@
+--- a/gqradio.desktop
++++ b/gqradio.desktop
+@@ -3,12 +3,12 @@
+ Comment=Radio tuner
+ Comment[fr]=Tuner radio
+ Exec=gqradio
+-Icon=gqradio.png
+-Info=Radio tuner app.
+-Info[fr]=Application tuner radio
+-Terminal=0
++Icon=gqradio
++X-Info=Radio tuner app.
++X-Info[fr]=Application tuner radio
++Terminal=false
+ Type=Application
+ StartupNotify=false
+ StartupWMClass=gqradio
+ Encoding=UTF-8
+-Categories=Application;AudioVideo;
++Categories=AudioVideo;
diff --git a/media-sound/gqradio/files/gqradio-1.9.2-underlinking.patch b/media-sound/gqradio/files/gqradio-1.9.2-underlinking.patch
index bcedc3e40f10..f6e75954607f 100644
--- a/media-sound/gqradio/files/gqradio-1.9.2-underlinking.patch
+++ b/media-sound/gqradio/files/gqradio-1.9.2-underlinking.patch
@@ -1,5 +1,5 @@
---- configure.in
-+++ configure.in
+--- a/configure.in
++++ b/configure.in
@@ -30,6 +30,16 @@
AC_DEFINE_UNQUOTED(GQRADIO_SKINDIR, "$prefix/share/gqradio/skins", [Location of skins])
AC_DEFINE_UNQUOTED(GQRADIO_HELPDIR, "$prefix/share/doc/gqradio-$VERSION", [Location of documentation files])
diff --git a/media-sound/gqradio/gqradio-1.9.2.ebuild b/media-sound/gqradio/gqradio-1.9.2.ebuild
index 7f87210ea6e2..235f711463f2 100644
--- a/media-sound/gqradio/gqradio-1.9.2.ebuild
+++ b/media-sound/gqradio/gqradio-1.9.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="An FM radio tuner app from the people who brought you GQmpeg"
HOMEPAGE="http://gqmpeg.sourceforge.net/radio.html"
@@ -11,16 +12,20 @@ SRC_URI="mirror://sourceforge/gqmpeg/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
RDEPEND=">=x11-libs/gtk+-2.4:2"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-devel/gettext
virtual/pkgconfig"
-DOCS="AUTHORS ChangeLog README SKIN-SPECS TODO"
+PATCHES=(
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-desktop-QA.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-underlinking.patch
+ default
+ mv configure.{in,ac} || die
eautoreconf
}