summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-12-19 15:35:44 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-12-19 15:37:00 -0500
commit2c359470f44a0b1f3a6df4363b08bdda6764bee8 (patch)
treec4ae365c36db0f5113eb89b93cd1b9d3684f2531
parentqt6-build.eclass: cleanup <6.5.3 and 6.6.0 workarounds (diff)
downloadgentoo-2c359470f44a0b1f3a6df4363b08bdda6764bee8.tar.gz
gentoo-2c359470f44a0b1f3a6df4363b08bdda6764bee8.tar.bz2
gentoo-2c359470f44a0b1f3a6df4363b08bdda6764bee8.zip
dev-python/PyQt6: drop 6.5.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-python/PyQt6/Manifest1
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.3.ebuild179
-rw-r--r--dev-python/PyQt6/files/PyQt6-6.5.2-qt660.patch23
-rw-r--r--profiles/base/package.use.mask7
4 files changed, 0 insertions, 210 deletions
diff --git a/dev-python/PyQt6/Manifest b/dev-python/PyQt6/Manifest
index 65cd26ee15f0..624cb4ac7cc0 100644
--- a/dev-python/PyQt6/Manifest
+++ b/dev-python/PyQt6/Manifest
@@ -1,2 +1 @@
-DIST PyQt6-6.5.3.tar.gz 1039271 BLAKE2B 965efa73daa83e46fbb1428b27f8bfc8e5cbfd4cfa5481b50835fdcc58f475416207a670882d47a0cc724e4dc06e0a00a512c5f83c4918134c2f1303aecda20e SHA512 a502693cc9e1887011466132cd85e232ce653bfc38519aed99a77332413bdb65a01ecad4680b831eb76365b086e6a3b52fa69017b39d95933a6372d2e7e8e4bb
DIST PyQt6-6.6.1.tar.gz 1043203 BLAKE2B dd2b6988ebeabaae47fe57c5c0d17fbe4b62c377262b4bb360adb7fd6724ccb6a67ba5c2bd7498df98db3ce6b00978f936b11a43b464c3c7af169f25b30ee1a6 SHA512 c2ff8c47c9b0e43c009d0c90f565a54344e6f384c67dd30c2d422465d0702c07713acc0095c8b67827d1146675611c07d548ba282a26e41bb60a0a21977a7a64
diff --git a/dev-python/PyQt6/PyQt6-6.5.3.ebuild b/dev-python/PyQt6/PyQt6-6.5.3.ebuild
deleted file mode 100644
index d34d5ff53a5b..000000000000
--- a/dev-python/PyQt6/PyQt6-6.5.3.ebuild
+++ /dev/null
@@ -1,179 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=sip
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1 flag-o-matic multiprocessing pypi qmake-utils
-
-# 'can' work with older Qt depending on features, but keeping it simple
-QT_PV=$(ver_cut 1-2):6
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64"
-# defaults match what is provided with qtbase by default (except testlib),
-# reduces the need to set flags but does increase build time a fair amount
-IUSE="
- bluetooth +dbus debug designer examples gles2-only +gui help
- multimedia +network nfc opengl pdfium positioning +printsupport
- qml quick quick3d serialport sensors spatialaudio speech +sql
- +ssl svg testlib webchannel websockets +widgets +xml
-"
-# see `grep -r "%Import " sip` and `grep qmake_QT project.py`
-REQUIRED_USE="
- designer? ( gui widgets )
- help? ( gui widgets )
- multimedia? ( gui network )
- opengl? ( gui )
- pdfium? ( gui )
- printsupport? ( gui widgets )
- qml? ( network )
- quick3d? ( gui qml )
- quick? ( gui qml )
- spatialaudio? ( multimedia )
- sql? ( widgets )
- svg? ( gui )
- testlib? ( gui widgets )
- webchannel? ( network )
- websockets? ( network )
- widgets? ( gui )
-"
-
-# may use qt private symbols wrt qtbase's :=
-DEPEND="
- >=dev-qt/qtbase-${QT_PV}=[dbus?,gles2-only=,gui?,network?,opengl?,sql?,ssl=,widgets?,xml?]
- bluetooth? ( >=dev-qt/qtconnectivity-${QT_PV}[bluetooth] )
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- sys-apps/dbus
- )
- designer? ( >=dev-qt/qttools-${QT_PV}[designer] )
- help? ( >=dev-qt/qttools-${QT_PV}[assistant] )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
- nfc? ( >=dev-qt/qtconnectivity-${QT_PV}[nfc] )
- opengl? (
- gles2-only? ( media-libs/libglvnd )
- )
- pdfium? ( >=dev-qt/qtwebengine-${QT_PV}[pdfium(-),widgets?] )
- positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
- qml? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
- quick3d? ( >=dev-qt/qtquick3d-${QT_PV} )
- quick? ( >=dev-qt/qtdeclarative-${QT_PV}[opengl] )
- sensors? ( >=dev-qt/qtsensors-${QT_PV} )
- serialport? ( >=dev-qt/qtserialport-${QT_PV} )
- speech? ( >=dev-qt/qtspeech-${QT_PV} )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
- websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
-"
-RDEPEND="
- ${DEPEND}
- >=dev-python/PyQt6-sip-13.6[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/PyQt-builder-1.15[${PYTHON_USEDEP}]
- >=dev-python/sip-6.7.12[${PYTHON_USEDEP}]
- >=dev-qt/qtbase-${QT_PV}
- dbus? ( virtual/pkgconfig )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.5.2-qt660.patch
-)
-
-src_prepare() {
- default
-
- # hack: qmake queries g++ or clang++ for info depending on which qtbase was
- # built with, but ignores CHOST failing with -native-symlinks (bug #726112)
- # and potentially using wrong information when cross-compiling
- mkdir "${T}"/cxx || die
- local cxx
- ! cxx=$(type -P "${CHOST}"-g++) || ln -s -- "${cxx}" "${T}"/cxx/g++ || die
- ! cxx=$(type -P "${CHOST}"-clang++) || ln -s -- "${cxx}" "${T}"/cxx/clang++ || die
- PATH=${T}/cxx:${PATH}
-}
-
-python_configure_all() {
- append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
- append-cxxflags ${CPPFLAGS} # respect CPPFLAGS notably for DISTUTILS_EXT=1
-
- pyqt_use_enable() {
- local state=$(usex ${1} --enable= --disable=)
- shift
- echo ${*/#/${state}}
- }
-
- DISTUTILS_ARGS=(
- --jobs="$(makeopts_jobs)"
- --qmake="$(qt6_get_bindir)"/qmake
- --qmake-setting="$(qt6_get_qmake_args)"
- --verbose
- --confirm-license
-
- --enable=QtCore
-
- $(pyqt_use_enable bluetooth QtBluetooth)
- $(pyqt_use_enable dbus QtDBus)
- $(pyqt_use_enable designer QtDesigner)
- $(pyqt_use_enable help QtHelp)
- $(pyqt_use_enable gui QtGui)
- #--disable=QtLocation # force-disabled in project.py
- $(pyqt_use_enable multimedia QtMultimedia \
- $(usev widgets QtMultimediaWidgets))
- $(pyqt_use_enable network QtNetwork)
- $(pyqt_use_enable nfc QtNfc)
- $(pyqt_use_enable opengl QtOpenGL \
- $(usev widgets QtOpenGLWidgets))
- $(pyqt_use_enable pdfium QtPdf \
- $(usev widgets QtPdfWidgets))
- $(pyqt_use_enable positioning QtPositioning)
- $(pyqt_use_enable printsupport QtPrintSupport)
- $(pyqt_use_enable qml QtQml)
- $(pyqt_use_enable quick QtQuick \
- $(usev widgets QtQuickWidgets))
- $(pyqt_use_enable quick3d QtQuick3D)
- --disable=QtRemoteObjects # not packaged
- $(pyqt_use_enable sensors QtSensors)
- $(pyqt_use_enable serialport QtSerialPort)
- $(pyqt_use_enable spatialaudio QtSpatialAudio)
- $(pyqt_use_enable sql QtSql)
- $(pyqt_use_enable svg QtSvg \
- $(usev widgets QtSvgWidgets))
- $(pyqt_use_enable testlib QtTest)
- $(pyqt_use_enable speech QtTextToSpeech)
- $(pyqt_use_enable webchannel QtWebChannel)
- $(pyqt_use_enable websockets QtWebSockets)
- $(pyqt_use_enable widgets QtWidgets)
- $(pyqt_use_enable xml QtXml)
-
- $(usev debug '--debug --qml-debug --tracing')
-
- $(usev !dbus --no-dbus-python)
- # note: upstream currently intentionally skips installing these two
- # plugins when using wheels w/ pep517 so, *if* something does need
- # them, it will need to be handled manually
- $(usev !designer --no-designer-plugin)
- $(usev !qml --no-qml-plugin)
-
- $(usev !gles2-only --disabled-feature=PyQt_OpenGL_ES2)
- $(usev !opengl --disabled-feature=PyQt_OpenGL)
- $(usev !ssl --disabled-feature=PyQt_SSL)
-
- # intended for Windows / Android or others
- --disable=QAxContainer
- --disabled-feature=PyQt_Permissions
- )
-}
-
-python_install_all() {
- einstalldocs
- use examples && dodoc -r examples
-}
diff --git a/dev-python/PyQt6/files/PyQt6-6.5.2-qt660.patch b/dev-python/PyQt6/files/PyQt6-6.5.2-qt660.patch
deleted file mode 100644
index f0e204238a0a..000000000000
--- a/dev-python/PyQt6/files/PyQt6-6.5.2-qt660.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Quick workaround to fix build with USE=sql for Qt6.6 due to [1]
-while waiting for PyQt6-6.6.0. Not a proper fix but nothing in
-tree needs this bit currently.
-
-USE=bluetooth is still broken, but is not essential (no revdeps),
-and can instead be masked for the time being.
-
-[1] https://github.com/qt/qtbase/commit/d924253c91
---- a/sip/QtCore/QtCoremod.sip
-+++ b/sip/QtCore/QtCoremod.sip
-@@ -24,3 +24,3 @@
-
--%Timeline {Qt_6_0_0 Qt_6_1_0 Qt_6_2_0 Qt_6_3_0 Qt_6_4_0 Qt_6_5_0}
-+%Timeline {Qt_6_0_0 Qt_6_1_0 Qt_6_2_0 Qt_6_3_0 Qt_6_4_0 Qt_6_5_0 Qt_6_6_0}
-
---- a/sip/QtSql/qsqlresult.sip
-+++ b/sip/QtSql/qsqlresult.sip
-@@ -65,3 +65,5 @@
- int boundValueCount() const;
-+%If (- Qt_6_6_0)
- QList<QVariant> &boundValues() const;
-+%End
- QString executedQuery() const;
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index 27e69a393c25..c321de1dc28c 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -55,13 +55,6 @@ dev-haskell/scientific test
dev-haskell/splitmix test
dev-haskell/tasty-expected-failure test
-# Ionen Wolkens <ionen@gentoo.org> (2023-10-10)
-# Broken with Qt6.6 and, given USE has no revdeps, simpler to just
-# mask for now to save desktop profile users (default bluetooth)
-# from failures. Update: could be cleaned up now but waiting for
-# 6.6.0 stable to avoid unnecessary rebuilds.
-~dev-python/PyQt6-6.5.3 bluetooth
-
# Matt Turner <mattst88@gentoo.org> (2023-09-14)
# Not ported to libsoup:3.0
app-office/abiword collab