summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-30 09:08:02 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-30 11:45:12 +0200
commit2c36a80437a0cffe12c56b55de0aacd1156ebbec (patch)
tree4f889584c76c4270f7a8e735515b0d3ea8d20394
parentapp-portage/nattka: Bump to 0.2.3 (diff)
downloadgentoo-2c36a804.tar.gz
gentoo-2c36a804.tar.bz2
gentoo-2c36a804.zip
dev-python/xmlschema: Bump to 1.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-1.1.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 88f96cf6efd8..d32a0b2528d7 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
DIST xmlschema-1.1.2.tar.gz 297566 BLAKE2B 828da26710ffd3cffbd15dfd320438e37516906726527468f0c5cc26e2d710320f39a6ea4c7959e4de081a35c0359cd55ed400edfa7acebbbeef6271f2e1f913 SHA512 dee3b854c74645cb85bc1464648909fe2497542d137c98d241201670d1536e7a47c5bc2d6a38e10fe07696fa34115d76eac3ac67a9279ea7d9a45722b4e80ba7
+DIST xmlschema-1.1.3.tar.gz 298490 BLAKE2B 70c24424fd6a5e87e07591451db920d22c1bf2c63c1908e008401eafe210b759894ba508011ee58e2c242ca5b3d424c86cdf7a65312e9df1cda426802af8e861 SHA512 df277cd75058e10b8e0505db51fc167c688fe4c3d319de289ac77faa37913f60d2697f4456e00d637c4a3c3f83d164619e0ce1b849e8c8ea3b5e1932b56044dc
diff --git a/dev-python/xmlschema/xmlschema-1.1.3.ebuild b/dev-python/xmlschema/xmlschema-1.1.3.ebuild
new file mode 100644
index 000000000000..e1579bdefa23
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-python/elementpath-1.4*[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}