summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-10-05 16:02:08 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-10-05 16:03:12 +0200
commit2c3d6db712c9ef67a4349fca7aff6256af39b037 (patch)
tree26e01ea5fc2f5f87d03412110b778e75dbf3033e
parentdev-python/pyzotero: Bump to 1.5.18 (diff)
downloadgentoo-2c3d6db7.tar.gz
gentoo-2c3d6db7.tar.bz2
gentoo-2c3d6db7.zip
dev-util/intel-graphics-compiler: reenable vectorcompiler
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.14062.11-vc.patch59
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.15136.4-r1.ebuild1
-rw-r--r--profiles/default/linux/package.use.mask5
3 files changed, 60 insertions, 5 deletions
diff --git a/dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.14062.11-vc.patch b/dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.14062.11-vc.patch
new file mode 100644
index 000000000000..778505f08068
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/files/intel-graphics-compiler-1.0.14062.11-vc.patch
@@ -0,0 +1,59 @@
+--- a/IGC/VectorCompiler/lib/GenXCodeGen/GenXSimdCFConformance.cpp
++++ b/IGC/VectorCompiler/lib/GenXCodeGen/GenXSimdCFConformance.cpp
+@@ -1867,11 +1867,13 @@ void GenXSimdCFConformance::ensureConformance() {
+ IID != GenXIntrinsic::genx_simdcf_unmask &&
+ IID != GenXIntrinsic::genx_simdcf_remask) {
+ EMValsStack.insert(*i);
++ #ifdef DEBUG_VERBOSE_ON
+ LLVM_DEBUG(if (auto *Inst = dyn_cast<Instruction>(i->getValue())) {
+ auto FuncName = Inst->getFunction()->getName();
+ dbgs() << "Entry EMVals " << FuncName << " - ";
+ i->getValue()->dump();
+ });
++ #endif
+ }
+ }
+ for (auto i = EMVals.begin(), e = EMVals.end(); i != e; ++i) {
+@@ -1919,6 +1921,7 @@ void GenXSimdCFConformance::ensureConformance() {
+ // been identified in the early pass, unless passes in between have
+ // transformed the code in an unexpected way that has made the simd CF
+ // non-conformant. Give an error here if this has happened.
++ #ifdef DEBUG_VERBOSE_ON
+ if (!GotosToLower.empty()) {
+ dbgs() << "Not empty GotosToLower:";
+ for (auto *Dump : GotosToLower)
+@@ -1929,6 +1932,7 @@ void GenXSimdCFConformance::ensureConformance() {
+ for (auto *Dump : JoinsToLower)
+ Dump->dump();
+ }
++ #endif
+ IGC_ASSERT_EXIT_MESSAGE(
+ GotosToLower.empty(),
+ "unexpected non-conformant SIMD CF in late SIMD CF conformance pass");
+@@ -2460,8 +2464,10 @@ static bool checkAllUsesAreSelectOrWrRegion(Value *V) {
+ auto User2 = cast<Instruction>(ui2->getUser());
+ unsigned OpNum = ui2->getOperandNo();
+ ++ui2;
++ #ifdef DEBUG_VERBOSE_ON
+ LLVM_DEBUG(dbgs() << "checkAllUsesAreSelectOrWrRegion: for user ";
+ User2->dump());
++ #endif
+
+ if (isa<SelectInst>(User2))
+ continue;
+@@ -3006,12 +3012,14 @@ bool GenXSimdCFConformance::getConnectedVals(
+ }
+ } else {
+ if (!UsersToLower.empty()) {
++ #ifdef DEBUG_VERBOSE_ON
+ LLVM_DEBUG(dbgs() << "getConnectedVals: find bad users:\n";
+ for (auto &BadUser
+ : UsersToLower) {
+ dbgs() << " ";
+ BadUser.dump();
+ });
++ #endif
+ return false;
+ }
+ }
+--
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.15136.4-r1.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.15136.4-r1.ebuild
index 4af5fe6fad51..96c33faba372 100644
--- a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.15136.4-r1.ebuild
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.15136.4-r1.ebuild
@@ -48,6 +48,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.0.9-no_Werror.patch"
"${FILESDIR}/${PN}-1.0.8173-opencl-clang_version.patch"
"${FILESDIR}/${PN}-1.0.8365-disable-git.patch"
+ "${FILESDIR}/${PN}-1.0.14062.11-vc.patch"
)
pkg_setup() {
diff --git a/profiles/default/linux/package.use.mask b/profiles/default/linux/package.use.mask
index d6ee6fb4c40a..5407972c13ac 100644
--- a/profiles/default/linux/package.use.mask
+++ b/profiles/default/linux/package.use.mask
@@ -1,11 +1,6 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Conrad Kostecki (conikost@gentoo.org> (2023-10-02)
-# Using VectorCompiler is currently broken on newer versions.
-# See https://github.com/intel/intel-graphics-compiler/issues/303
->=dev-util/intel-graphics-compiler-1.0.15136.4 vc
-
# Sam James <sam@gentoo.org> (2023-06-06)
# Needs linux-only dev-libs/libaio.
app-emulation/qemu -aio