summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-08 12:15:55 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-08 12:57:42 -0500
commit2c457f36dec3a9a52cbf19f7c0891febdd459d9a (patch)
tree183db32178a535b8676527065838136cd6b79306
parentdev-vcs/git-imerge: bump to EAPI 6, add maintainer-needed (diff)
downloadgentoo-2c457f36dec3a9a52cbf19f7c0891febdd459d9a.tar.gz
gentoo-2c457f36dec3a9a52cbf19f7c0891febdd459d9a.tar.bz2
gentoo-2c457f36dec3a9a52cbf19f7c0891febdd459d9a.zip
dev-vcs/topgit: bump to EAPI 6, add maintainer-needed
Package-Manager: portage-2.2.28
-rw-r--r--dev-vcs/topgit/metadata.xml1
-rw-r--r--dev-vcs/topgit/topgit-0.9-r1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-vcs/topgit/metadata.xml b/dev-vcs/topgit/metadata.xml
index ad17ee0507f9..a4bff25eb375 100644
--- a/dev-vcs/topgit/metadata.xml
+++ b/dev-vcs/topgit/metadata.xml
@@ -1,6 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="github">greenrd/topgit</remote-id>
</upstream>
diff --git a/dev-vcs/topgit/topgit-0.9-r1.ebuild b/dev-vcs/topgit/topgit-0.9-r1.ebuild
new file mode 100644
index 000000000000..17c85218fee6
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.9-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://github.com/greenrd/topgit"
+SRC_URI="https://github.com/greenrd/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed
+ virtual/awk"
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" sharedir="${D}/usr/share/doc/${PF}" install
+
+ newbashcomp contrib/tg-completion.bash tg
+ dodoc README
+}