summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-09-30 19:18:58 +0800
committerJason Zaman <perfinion@gentoo.org>2018-09-30 19:19:49 +0800
commit2c484ac90e39d890a71ef54d64c13a1352737ed9 (patch)
treee23b1dcaed5f00d66d231231eea5c3d2dcd3e26e
parentpackage.mask: Last rite ag-projects' dev-python/python-* packages (diff)
downloadgentoo-2c484ac90e39d890a71ef54d64c13a1352737ed9.tar.gz
gentoo-2c484ac90e39d890a71ef54d64c13a1352737ed9.tar.bz2
gentoo-2c484ac90e39d890a71ef54d64c13a1352737ed9.zip
sci-visualization/tensorboard: dont unvendor tensorflow_serving
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--sci-visualization/tensorboard/tensorboard-1.11.0-r1.ebuild (renamed from sci-visualization/tensorboard/tensorboard-1.11.0.ebuild)14
1 files changed, 10 insertions, 4 deletions
diff --git a/sci-visualization/tensorboard/tensorboard-1.11.0.ebuild b/sci-visualization/tensorboard/tensorboard-1.11.0-r1.ebuild
index 5e3272e5be05..c7bf274d1a98 100644
--- a/sci-visualization/tensorboard/tensorboard-1.11.0.ebuild
+++ b/sci-visualization/tensorboard/tensorboard-1.11.0-r1.ebuild
@@ -23,6 +23,7 @@ RDEPEND="
dev-python/protobuf-python[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]"
BDEPEND="app-arch/unzip"
PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
@@ -30,10 +31,15 @@ PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
S="${WORKDIR}/${PN}"
src_prepare() {
- rm -rf "${S}/_vendor" || die
- find "${S}" -name '*.py' -exec sed -i -e \
- 's/^from tensorboard\._vendor import /import /;
- s/^from tensorboard\._vendor\./from /' {} + || die "failed to unvendor"
+ rm -rf "${S}/_vendor/bleach" || die
+ rm -rf "${S}/_vendor/html5lib" || die
+
+ find "${S}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import html5lib/import html5lib/' \
+ -e 's/^from tensorboard\._vendor import bleach/import bleach/' \
+ -e 's/^from tensorboard\._vendor\.html5lib/from html5lib/' \
+ -e 's/^from tensorboard\._vendor\.bleach/from bleach/' \
+ {} + || die "failed to unvendor"
eapply_user
}