summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-26 10:27:55 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-26 10:37:40 +0200
commit2c6515e765ac1d38d8c0eeabf0bd261056d8027f (patch)
tree33ab144666c1446e84f2551af45879b895b34bdc
parentgames-util/cartridges: drop old 1.5.4 (diff)
downloadgentoo-2c6515e765ac1d38d8c0eeabf0bd261056d8027f.tar.gz
gentoo-2c6515e765ac1d38d8c0eeabf0bd261056d8027f.tar.bz2
gentoo-2c6515e765ac1d38d8c0eeabf0bd261056d8027f.zip
games-util/cartridges: bump to 2.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--games-util/cartridges/Manifest1
-rw-r--r--games-util/cartridges/cartridges-2.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/games-util/cartridges/Manifest b/games-util/cartridges/Manifest
index fcacbc75ee6d..431a10e95bde 100644
--- a/games-util/cartridges/Manifest
+++ b/games-util/cartridges/Manifest
@@ -1,2 +1,3 @@
DIST cartridges-1.5.6.tar.gz 1305623 BLAKE2B 20d95f2153e090db3ffee36361e8595ea3cca37a7f5971f945a41bec40df3fa9663449ed10a8d6349738838d592746372d2e3091589538266ef3bd4aed3edd6c SHA512 4e4a94ed31fc416accfa1b5f06580f3a5180665d931bee933b8ed29f4069f8939a60b2947740e7223e570be2116a55b1e3698e40f4529cf4c974636af6384456
DIST cartridges-2.0.4.tar.gz 1332584 BLAKE2B 07cd5f19ad74c169cd1a98136920fc8f10fda001f1cde93f26fd0a77e556f0406995efc07b54722571f468983b9af53d7db2ce95e434d91f7e10a7b5855d1b46 SHA512 892be1a587aa7ad4baed457069fdf7019472bcf0d7acf301e8aca96719ebe259f59989fc966cb32376326273406ac688a51e95bd395b5de7b63c85c031dcf15a
+DIST cartridges-2.1.tar.gz 1336661 BLAKE2B 9edf5c1a22959f46250dd621b5f1641b3b0119fb47fcf2ca8230209739eca2a7775eee911e5ee9c67c5408bc2c3135688a2ee66fc160ffefc2923c8a4695295d SHA512 74e3a4d29c136f83ca91cb7d19d311a96353b254a4b753e69f58da219895dabd6e1c5dbf8561bb0536d840b9d8b151ecb112c96f4b4cfd0d6cd85f4fc27cf092
diff --git a/games-util/cartridges/cartridges-2.1.ebuild b/games-util/cartridges/cartridges-2.1.ebuild
new file mode 100644
index 000000000000..05c8ac27f772
--- /dev/null
+++ b/games-util/cartridges/cartridges-2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Simple game launcher written in Python using GTK4 and Libadwaita"
+HOMEPAGE="https://github.com/kra-mo/cartridges/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kra-mo/${PN}.git"
+else
+ SRC_URI="https://github.com/kra-mo/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/blueprint-compiler
+ dev-util/desktop-file-utils
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.4-dont-validate-appstream.patch )
+
+src_install() {
+ meson_src_install
+
+ python_fix_shebang "${ED}"/usr/bin
+ python_optimize "${ED}"/usr/share/cartridges/cartridges
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}