summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-06-05 11:49:48 +0200
committerPacho Ramos <pacho@gentoo.org>2017-06-05 11:49:48 +0200
commit2c6765dcb5d7f66054d0d2a04219df35faf4c607 (patch)
treeb0c9475646614b9cbd1c3eb32d10d9c5f6d7405e
parentpackage.mask: unmask audacity-2.1.3 (#584024) (diff)
downloadgentoo-2c6765dc.tar.gz
gentoo-2c6765dc.tar.bz2
gentoo-2c6765dc.zip
app-dicts/opendict: Version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--app-dicts/opendict/Manifest1
-rw-r--r--app-dicts/opendict/opendict-0.6.7.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-dicts/opendict/Manifest b/app-dicts/opendict/Manifest
index c953cafe80cf..15a8892d430b 100644
--- a/app-dicts/opendict/Manifest
+++ b/app-dicts/opendict/Manifest
@@ -1 +1,2 @@
DIST opendict-0.6.3.tar.gz 132515 SHA256 dad7723512768aeae65fead0f06a3c973b161a86658b94a66c4945beb12f45dc SHA512 687afba45f9fd271acee9f72fd3971fbc624588fe0f4194ad4499e2e64259a59c516854a7b0b1c02b3e214bf6e77e52b5b0713430e3cd5e0127c5b3c8fc02f5c WHIRLPOOL 06a48141bb1da7557d616deda3c4c18500171d4c158cb5f5cc83ca9f1f8037584ade85a742c88a4b6ab667bd6586492fed075e6a4e69fa51c8e37ece75880a62
+DIST opendict-0.6.7.tar.gz 169580 SHA256 d376c8a81e5747e40775214177df9d0f04d6441acaea7435e0cb7e770b6c460f SHA512 ef97ec84591bda4d8d4746fa4532de109cf03d89dfd5aa20e1775224c687b503759c020b2286e5cedd395ebce5db3b2a10495adc31fcc31dbd4fddfca6fee1f8 WHIRLPOOL 215a3f9ec80bf07c662f5cc35f1e698cfabbb74edd8c641681b562bc6a4a47b4b2fe1e889288abb8e5f213441cd501cf9c6d2ad4581501a5c90bb0048623c3d7
diff --git a/app-dicts/opendict/opendict-0.6.7.ebuild b/app-dicts/opendict/opendict-0.6.7.ebuild
new file mode 100644
index 000000000000..026546d15248
--- /dev/null
+++ b/app-dicts/opendict/opendict-0.6.7.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="OpenDict is a free cross-platform dictionary program"
+HOMEPAGE="http://opendict.sourceforge.net/"
+SRC_URI="mirror://sourceforge/opendict/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="If you want system-wide plugins, unzip them into
+${ROOT}usr/share/${PN}/dictionaries/plugins
+
+Some are available from http://opendict.sourceforge.net/?cid=3"
+
+src_prepare() {
+ sed -e "s:), '..')):), '../../../../..', 'share', 'opendict')):g" \
+ -i "${S}/lib/info.py"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # override gnome2_src_configure
+ default
+}
+
+src_compile() {
+ # evil makefile
+ :
+}
+
+src_install() {
+ # makefile is broken, do it manually
+
+ dodir /usr/share/${PN}/dictionaries/plugins # global dictionary plugins folder
+
+ # Needed by GUI
+ insinto /usr/share/${PN}
+ doins "${S}"/copying.html
+
+ insinto /usr/share/${PN}/pixmaps
+ doins "${S}"/pixmaps/*
+
+ DHOME="$(python_get_sitedir)/opendict"
+ insinto "${DHOME}/lib"
+ doins -r "${S}"/lib/*
+ exeinto "${DHOME}"
+ python_fix_shebang opendict.py
+ doexe opendict.py
+
+ dosym "${DHOME}/opendict.py" /usr/bin/opendict
+
+ domenu misc/${PN}.desktop
+
+ insinto /usr/share/icons/hicolor/24x24/apps/
+ newins "${S}/pixmaps/icon-24x24.png" opendict.png
+ insinto /usr/share/icons/hicolor/32x32/apps/
+ newins "${S}/pixmaps/icon-32x32.png" opendict.png
+ insinto /usr/share/icons/hicolor/48x48/apps/
+ newins "${S}/pixmaps/icon-48x48.png" opendict.png
+ insinto /usr/share/icons/hicolor/scalable/apps/
+ newins "${S}/pixmaps/SVG/icon-rune.svg" opendict.svg
+
+ doman opendict.1
+ dodoc README.txt TODO.txt doc/Plugin-HOWTO.html
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}