summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-03-14 13:43:52 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-03-16 21:18:09 +0200
commit2c73b05b79a373ac28c0882fbd88ff7c5404059c (patch)
tree6bbf55925c3d7eba44df1f5f9a063a465abfd913
parentgui-wm/wayfire: drop 0.7.5-r1, 0.8.0 (diff)
downloadgentoo-2c73b05b79a373ac28c0882fbd88ff7c5404059c.tar.gz
gentoo-2c73b05b79a373ac28c0882fbd88ff7c5404059c.tar.bz2
gentoo-2c73b05b79a373ac28c0882fbd88ff7c5404059c.zip
gui-apps/wf-shell: add 0.8.1
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--gui-apps/wf-shell/Manifest1
-rw-r--r--gui-apps/wf-shell/wf-shell-0.8.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gui-apps/wf-shell/Manifest b/gui-apps/wf-shell/Manifest
index b85a8c694114..68143c24636f 100644
--- a/gui-apps/wf-shell/Manifest
+++ b/gui-apps/wf-shell/Manifest
@@ -1,2 +1,3 @@
DIST wf-shell-0.7.0.tar.xz 9014840 BLAKE2B f2e1ffb76de79db580227ddefc10c9f3431c92f77e6519da1102e7c4456bb30c4f25c82570a5b2796985dac00be65f9428ac6682e80920ed22359f63e3e6a84d SHA512 3d72c5d399280ee9da841a417faf696f8baa40edc1040bc1f354f113a8e431dbab428c93928b1d3faa520e35211345cabb5c70f55e10cfb7a4c321a6db19df90
DIST wf-shell-0.8.0.tar.xz 9100508 BLAKE2B 0867f9968fca25d183fb912e01afc55ae6c9e3a0645eb63b2622ed53bb5d6538827a8e1bb6c68be4885f0c1513e76f0fd8f580402885bfa49dcbc7a0b8b02b49 SHA512 cdaebb4aabcfcb4a4d2ef0f7845348892e5731cc44417861b958d3f067f19b6bab002845d7663ef50f57e462664ff1ca0cdab74257109211db8fa20a47ef53ae
+DIST wf-shell-0.8.1.tar.xz 9161772 BLAKE2B d778b2ed214dbb1b072400a85021d3ef4e590bc707417cf2de486c9211fdf3d1fa1c14d786363bc7dd4daeeb39406d6aa2e2c3c0b607cb9b6c87151d330a3983 SHA512 b0d283dee712ed01bdabb373f8144e6c231aa68669be8851e6603678972d9f2bdcadda773df49510c902f8e8845fdb767f9da65356640fe37843dd92d0c240f2
diff --git a/gui-apps/wf-shell/wf-shell-0.8.1.ebuild b/gui-apps/wf-shell/wf-shell-0.8.1.ebuild
new file mode 100644
index 000000000000..dfc67326dbca
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.8.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wf-shell.git"
+ SLOT="0/0.8"
+else
+ SRC_URI="https://github.com/WayfireWM/wf-shell/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SLOT="0/$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+IUSE="+pulseaudio"
+
+# no tests
+RESTRICT="test"
+
+DEPEND="
+ dev-cpp/gtkmm:3.0[wayland]
+ dev-libs/gobject-introspection
+ dev-libs/libdbusmenu[gtk3]
+ >=gui-libs/gtk-layer-shell-0.6
+ dev-libs/wayland
+ >=gui-libs/wf-config-0.8.0
+ gui-wm/wayfire
+ pulseaudio? ( media-libs/libpulse )
+"
+RDEPEND="${DEPEND}
+ gui-apps/wayland-logout
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ -Dwayland-logout=false
+ )
+ meson_src_configure
+}