summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-27 09:08:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-27 10:29:12 +0200
commit2c7fa120eeadfc056d0ae12c722db16acb28646e (patch)
treedef868f2bbe739ec8204b811ccfa4da7e22ca4ee
parentdev-python/python-engineio: Bump to 4.3.0 (diff)
downloadgentoo-2c7fa120.tar.gz
gentoo-2c7fa120.tar.bz2
gentoo-2c7fa120.zip
dev-python/google-auth: Bump to 2.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.3.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 66decc0e8bdd..7f68676a0406 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -2,3 +2,4 @@ DIST google-auth-2.1.0.tar.gz 181817 BLAKE2B 806f3541163bd2f66a533730eb0064b4697
DIST google-auth-2.2.0.tar.gz 183667 BLAKE2B ac71dfe657126f96fd78f4fde110630dd5e1fc2864579a199309725795ba337fa7a2771cccbaba9d12fd35639ef67a78cb71bfd2e1a8e963cfc62507b2513ec3 SHA512 00a2a28f5237bba58a578726ac6d3290eec37486343a0f2c1c1764c14db137cd68db776890cd2556516579b54ddbb7516c08782959f87867a1e30756821e489c
DIST google-auth-2.2.1.tar.gz 183909 BLAKE2B 4c18f332f068573567af5100828b3902db17e46c47087569386ad3b012e45ecb841709376fae7f14920e3dfdb0124b9fd002b670b565b9c641dc9ff4ef5cc507 SHA512 245e6b8d27ff49e47093dc2f50e97a57031c93090900b5578a91ab335560b7fec1aced1faf822826263a00dfaf282eb147a4e389c13546f2e34d09f1ef1ca285
DIST google-auth-2.3.0.tar.gz 184993 BLAKE2B ac1392ca61e092e3e53c9e936e2d0bd11aeb8f33cace2458e80055734a96a05294335a9273acfcc3f385f423ed537d544404e41599cb6a75b21a10998fd72562 SHA512 cf0040d238880ea4bbad64f0a47311f2ed3922a7301a0d5287319b39ea8e76dca66dc78fd860cc12386b078bd2147a1cba01de97381420ef94cc44fca0c90ad1
+DIST google-auth-2.3.2.tar.gz 186112 BLAKE2B df2321252984ea43def8ec703590d153ecbd144f385a4915ce8f52e4cb71d66e31929f95a1ac783c4c4436a454b81a71d13517d38454892203c8ef19dbd80822 SHA512 1a7c828ecf529e8e64f946a5ee1923bed1544d4828b00449d027b0898af47e99b90be1a490b60e19a133fb59397f8860265306cd3dbaa8600bef823da1e4a215
diff --git a/dev-python/google-auth/google-auth-2.3.2.ebuild b/dev-python/google-auth/google-auth-2.3.2.ebuild
new file mode 100644
index 000000000000..01d1b603755a
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}