summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-05-28 17:11:54 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-05-28 17:17:18 -0500
commit2c81a00c035017c8943747cd9b2372e0a7c3229a (patch)
tree3e71c0afb660a05e7254323c3d2e6896adcc16b1
parentdev-util/astyle: spliting into sub-slots (diff)
downloadgentoo-2c81a00c035017c8943747cd9b2372e0a7c3229a.tar.gz
gentoo-2c81a00c035017c8943747cd9b2372e0a7c3229a.tar.bz2
gentoo-2c81a00c035017c8943747cd9b2372e0a7c3229a.zip
dev-util/astyle: minor cleanup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-util/astyle/astyle-3.0.1-r1.ebuild21
-rw-r--r--dev-util/astyle/astyle-3.1-r2.ebuild21
2 files changed, 20 insertions, 22 deletions
diff --git a/dev-util/astyle/astyle-3.0.1-r1.ebuild b/dev-util/astyle/astyle-3.0.1-r1.ebuild
index cdc9411aa460..24d96553a978 100644
--- a/dev-util/astyle/astyle-3.0.1-r1.ebuild
+++ b/dev-util/astyle/astyle-3.0.1-r1.ebuild
@@ -52,18 +52,17 @@ src_install() {
pushd src/bin >/dev/null || die
dobin ${PN}
- # ex: libastyle.so.3.0.1
- local libastylename=lib${PN}.so.${PV}
- dolib.so ${libastylename}
- # ex: libastyle.so.3
- local libdestdir=/usr/$(get_libdir)
- dosym ${libastylename} ${libdestdir}/lib${PN}.so.$(get_major_version)
- dosym ${libastylename} ${libdestdir}/lib${PN}.so
+ local libastylename="lib${PN}.so.${PV}"
+ local libastylejname="lib${PN}j.so.${PV}"
+ local libdestdir="${EPREFIX}/usr/$(get_libdir)"
+
+ dolib.so "${libastylename}"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so.$(get_major_version)"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so"
if use java ; then
- local libastylejname=lib${PN}j.so.${PV}
- dolib.so ${libastylejname}
- dosym ${libastylejname} ${libdestdir}/lib${PN}j.so.$(get_major_version)
- dosym ${libastylejname} ${libdestdir}/lib${PN}j.so
+ dolib.so "${libastylejname}"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so.$(get_major_version)"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so"
fi
if use static-libs ; then
dolib.a lib${PN}.a
diff --git a/dev-util/astyle/astyle-3.1-r2.ebuild b/dev-util/astyle/astyle-3.1-r2.ebuild
index 5982affd7b59..ed480708102f 100644
--- a/dev-util/astyle/astyle-3.1-r2.ebuild
+++ b/dev-util/astyle/astyle-3.1-r2.ebuild
@@ -52,18 +52,17 @@ src_install() {
pushd src/bin >/dev/null || die
dobin ${PN}
- # ex: libastyle.so.3.0.1
- local libastylename=lib${PN}.so.${PV}.0
- dolib.so ${libastylename}
- # ex: libastyle.so.3
- local libdestdir=/usr/$(get_libdir)
- dosym ${libastylename} ${libdestdir}/lib${PN}.so.$(get_major_version)
- dosym ${libastylename} ${libdestdir}/lib${PN}.so
+ local libastylename="lib${PN}.so.${PV}"
+ local libastylejname="lib${PN}j.so.${PV}"
+ local libdestdir="${EPREFIX}/usr/$(get_libdir)"
+
+ dolib.so "${libastylename}"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so.$(get_major_version)"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so"
if use java ; then
- local libastylejname=lib${PN}j.so.${PV}.0
- dolib.so ${libastylejname}
- dosym ${libastylejname} ${libdestdir}/lib${PN}j.so.$(get_major_version)
- dosym ${libastylejname} ${libdestdir}/lib${PN}j.so
+ dolib.so "${libastylejname}"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so.$(get_major_version)"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so"
fi
if use static-libs ; then
dolib.a lib${PN}.a