summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-10-26 09:09:11 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-26 15:18:00 +0200
commit2c843c86be4d7c1f8c1c697aa759eb12b86c9bba (patch)
treed4b71a1b43522f974fa18e2d66c8ecb62dfbc538
parentapp-admin/mongo-tools: drop old (diff)
downloadgentoo-2c843c86.tar.gz
gentoo-2c843c86.tar.bz2
gentoo-2c843c86.zip
app-admin/mongo-tools: bump to 4.0.3
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-4.0.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index 122c15cbe0dc..2c0f74ff36b5 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -3,3 +3,4 @@ DIST mongo-tools-3.4.10.tar.gz 4719399 BLAKE2B 8165248bf58f2ea2b02e365a3609c72b7
DIST mongo-tools-3.4.16.tar.gz 4697191 BLAKE2B 2e9a0e7dc8016d3e7d7c7f8d0cf80a97d3d199603c0b8b791df5a0d79d418ffaa232eee694047a7ca11fa7623023b4123becd437cfe3dec11e26cd525720bcad SHA512 b40c6dee75d860de1da73faf79f5f68c098ce7c80681486c66fff04a937474dcede91c7be907a8e36033b3898f7499e8f53271944c0df3360756c27361efb6f5
DIST mongo-tools-3.6.8.tar.gz 4723878 BLAKE2B a1693024d60f69d25c268eaaa30a478b1e4c0042c5fb7a3fd6252ed00aef2fee3fba94516fe825165a1a57887ed38e4fbce488c48ddd4f45349f0b7a1b244020 SHA512 359e8ce2d847d005d48ff12bc2e8af73213d81cd1521d2b5b5ac94792468218248bebbe808e1bd8fd49234eab8480608f294c1b63f317aed58f456b84ef17dcf
DIST mongo-tools-4.0.2.tar.gz 10872395 BLAKE2B 6d02a51677509abb5a00f7f4f324a2c979d7e55ebd55754023c80e51e9e8121bea84692574739f83882c0426074c0a3a5c5df2cb8cba58ee80c06e5a75504a8d SHA512 45971d96c512a920c40052f0d11097e88db137e975125de375a63e8f0eefbe22ae5252d239455c60e12ef65e0abce7a658dfb9dda0cbcc153718bb6711cf5e43
+DIST mongo-tools-4.0.3.tar.gz 10874727 BLAKE2B 3e5d07b8ae797d0876b68a3018806e91a30758415aaa236423648a77f5e0d475848060516ee0da91a8448813a12a685410b93bf219b8180beb91f448e329a532 SHA512 cbe74b3fdebd0d4f6be6e3acf7f55f5f1a551b0ad1a23d82782643d2a9eb9ea4b7e0133985485b8c5a88c1fea26595e3ed9c759f1f63b578b6472d850154d67b
diff --git a/app-admin/mongo-tools/mongo-tools-4.0.3.ebuild b/app-admin/mongo-tools/mongo-tools-4.0.3.ebuild
new file mode 100644
index 000000000000..5cf7cbaadac3
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-4.0.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # 1) ensure we use bash wrt #582906
+ # 2) do not substitute version because it uses git
+ sed -e 's@/bin/sh@/bin/bash@g' \
+ -e '/^sed/,+3d' \
+ -e '/^stty/d' \
+ -e '/^mv/d' \
+ -i build.sh || die
+
+ # build pie to avoid text relocations wrt #582854
+ # skip on ppc64 wrt #610984
+ if ! use ppc64; then
+ sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
+ fi
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ ./build.sh "${myconf[@]}" || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}