summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-24 07:29:55 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-24 07:59:57 +0100
commit2c85deb1702698f8251444a1dce5381a43ef58d1 (patch)
treefbe483bd05d87439f6a4dcccd863f543f9f9ec62
parentdev-python/setuptools: Bump to 69.0.3 (diff)
downloadgentoo-2c85deb1702698f8251444a1dce5381a43ef58d1.tar.gz
gentoo-2c85deb1702698f8251444a1dce5381a43ef58d1.tar.bz2
gentoo-2c85deb1702698f8251444a1dce5381a43ef58d1.zip
dev-python/ensurepip-setuptools: Bump to 69.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ensurepip-setuptools/Manifest1
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.3.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/Manifest b/dev-python/ensurepip-setuptools/Manifest
index 45828940e5fe..15bc7702217c 100644
--- a/dev-python/ensurepip-setuptools/Manifest
+++ b/dev-python/ensurepip-setuptools/Manifest
@@ -1 +1,2 @@
DIST setuptools-69.0.2-py3-none-any.whl 819519 BLAKE2B 0145a60d8b2e2a2733a8c9281caf633241cadd6a84a1974cfbab4938ec310b3e2c7bbe0bf252a4dafee9b354c3b1822573b8abc6841df237ac54131a10e19571 SHA512 9c602118b656590dd02684f07ed4951198fa1929df5e3da3dd9624c83bcde481e2b01141963909b2c18c8a54c7e468050de0245adfe1a6f5bca6afc0c06513f5
+DIST setuptools-69.0.3-py3-none-any.whl 819530 BLAKE2B 6ecef64755181255d935e234f77db3a4a9ce6426621d5d95196f55820a6bd62ff6bd3efcbf2e66221501b0c7c5296a35f80d275c59a8075392a0e802ee6713f1 SHA512 20c68e4f279a133f33ac85885b2c7e05b68c8c2faf15c9bb251229a6668c5c6b54c4065c54a0b711dae36d7fd161d3dc34218c579e739a2b2c573b85ccc79820
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.3.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.3.ebuild
new file mode 100644
index 000000000000..8346a1bd0f6d
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}