summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-28 05:29:32 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-28 06:06:34 +0100
commit2cb72c2406b601f33e8bf4e999448f56e140f921 (patch)
tree09307dfeb7a34da5af2180bf4cd4ffb873dd9464
parentdev-python/botocore: Bump to 1.29.80 (diff)
downloadgentoo-2cb72c24.tar.gz
gentoo-2cb72c24.tar.bz2
gentoo-2cb72c24.zip
dev-python/boto3: Bump to 1.26.80
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.80.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index f52714e53694..3aa651fc728b 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,2 +1,3 @@
DIST boto3-1.26.74.gh.tar.gz 602525 BLAKE2B 6d9b397864649ecd9b3f46bcee832c57cdce809545522f3beaf0d2eb98ca1f99e5fcab132f3389a4b2edcd585d9f6759de961b1f83f5912420629b6b03092c36 SHA512 eba11711dbd77988deb1695b954b6eb931b8ad49f96971e221415355de9bd2f3015b5a58be34a7378180f59500f9c15135192ccb97454141dbcaa664f0183627
DIST boto3-1.26.79.gh.tar.gz 605312 BLAKE2B c36b86ab289be9c08a1ab43274a4f4db71cede08598b6f8092af8404bc9994e345b263b144ee3a1974ea276fce63c330d7ffa6335bb889bea32e380e9003a8c7 SHA512 cfc789296b904c0c3bd3999153067f4fb174b323f0fbd22e8f4a49aed98338e20fd238876e2f55f608f5d6b60b584e15d370400e8d0a8a00b0689e0867d00f05
+DIST boto3-1.26.80.gh.tar.gz 606204 BLAKE2B ae80c1ec7e99f48844c4eec39df1f6802df1fbbf2d94f1b7ddc04c7a21cb885823ebadb11cf9e81b51af9aa5f09775c02e52e926b94c49331307873b86702446 SHA512 e4ab89f2afe506d7d1ba9e1615e3a92ba4bf5dc9a85d3a14f034c1b14733d99cebf594bb6dc80914bf444da34d09c045c8933cf3c97e6ccfa9e31901e99d76ee
diff --git a/dev-python/boto3/boto3-1.26.80.ebuild b/dev-python/boto3/boto3-1.26.80.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.80.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}