summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-19 04:46:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-19 05:16:37 +0200
commit2cb97f6517faac048dca783e4f262f776f25a8d9 (patch)
tree40b18f39a84c13235215eddb29780c9c970c9bb1
parentapp-admin/awscli: Bump to 1.29.50 (diff)
downloadgentoo-2cb97f6517faac048dca783e4f262f776f25a8d9.tar.gz
gentoo-2cb97f6517faac048dca783e4f262f776f25a8d9.tar.bz2
gentoo-2cb97f6517faac048dca783e4f262f776f25a8d9.zip
dev-python/trove-classifiers: Bump to 2023.9.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2023.9.19.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 341fe5f41064..987ae20e50ac 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1 +1,2 @@
DIST trove-classifiers-2023.8.7.tar.gz 15856 BLAKE2B b20befe256e51704b4974ba7b3bcae88ff2ae1f1281da145f16a77963a75b3d2a58aa5914d622e8687a0e08915ae92783c4782a90390b53a0f346d829dce8cd3 SHA512 d414f5e71abf0eef3593c9509c93b4d3dbbf0b8f6ffacc85acd43be9e0f31d924757868e86bb069d9f0475731c811229ffc827568fe957fef850e71a0a5119fa
+DIST trove-classifiers-2023.9.19.tar.gz 15865 BLAKE2B 2a84af01c16a728f708775dce6c3b4da564072cdcb6cdb6fea8014ee27744a657d8dc10663eca9fe4f9c9dec6faaa2684b10fe08d827ab52d6a61f16b557b40f SHA512 09979aacca745459f075cce85c483113955e0d218079132478596f350b7d7788d1a734dc82364194df9b31e4c109a806c50db4bb122b1f5bf747d9e7a0616143
diff --git a/dev-python/trove-classifiers/trove-classifiers-2023.9.19.ebuild b/dev-python/trove-classifiers/trove-classifiers-2023.9.19.ebuild
new file mode 100644
index 000000000000..3c130311d42a
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2023.9.19.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}