summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-05-13 11:22:03 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-13 11:44:26 +0200
commit2cc75094bf86c288f89032b9221a88205e5767ee (patch)
treedb4884bd7ee03812ee8f6b04101af166903ae3ce
parentmedia-libs/alsa-lib: Bump to version 1.1.9 (diff)
downloadgentoo-2cc75094bf86c288f89032b9221a88205e5767ee.tar.gz
gentoo-2cc75094bf86c288f89032b9221a88205e5767ee.tar.bz2
gentoo-2cc75094bf86c288f89032b9221a88205e5767ee.zip
media-sound/alsa-utils: Bump to version 1.1.9
Reported-by: Greg Turner <gmt@be-evil.net> Bug: https://bugs.gentoo.org/685510 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-sound/alsa-utils/Manifest1
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.1.9.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
index 6734ac3cbbf8..5c92197bb89e 100644
--- a/media-sound/alsa-utils/Manifest
+++ b/media-sound/alsa-utils/Manifest
@@ -2,3 +2,4 @@ DIST alsa-utils-1.1.2.tar.bz2 1193140 BLAKE2B 8c9d3baae1530a399299379963e68c50d2
DIST alsa-utils-1.1.6.tar.bz2 1203722 BLAKE2B e098ecbc5835c8ecd311a4df1ab51a709200b0d3666437f7f059d3842f07e1200a934b951e8e2c8ecedbe0aef4e2c766d875df577662eb21ce989807941ab6b7 SHA512 24d0ffaeeccecb3276d7d35ef51e6de6026a63fa5a1a1e4605b024f54d8097717e97ec9d33cfe50830ad17e4a89268ca24b065039b0df7f9fbe02b570617aa58
DIST alsa-utils-1.1.7.tar.bz2 1205754 BLAKE2B 419fa61fe85750ed26ab2b1dfe87adc7898f8c95dfe082993c0d5ee7755c4cb6563000555f44267608a2138d033e7011e7c67d98b714fdf1884cc03a8fd50ed3 SHA512 5da9b03e219d67634307bd5bb06b76734db5286221bec11658ce9c4dfca8ed639a4155ed90450f1d6c8db322960bb023ced0873e276500ce24f14fab17ceeb65
DIST alsa-utils-1.1.8.tar.bz2 1262174 BLAKE2B 643017f8f31d88356a2a55b5b1249d5b705daa7bd38e6d5e8835a21a9aefeca2fb1a7444c5709516ace0eecdfd5b410b5b24008abebb7ca917763108637bbcca SHA512 f877b491840126420dd9847347d0af865b6d03eccac2e2c3853cdbc76e91899f5a5139753cc41a4db942e7999c8d53cf9bd57d2fd5e1d32c872871b2d25146d9
+DIST alsa-utils-1.1.9.tar.bz2 1268833 BLAKE2B 56fe00bd7dce21969f9f91d1d82a6644da338208bfa646fc2a46d38f2d1d937b55b90acc5f75bb630aa288dee458c9f555a5727990c5cd7a59b627cb1ecf1e2c SHA512 92fa689ea5897150972d5376e7999ff060cad09cb0b06991d81c87b61a243ecec944e2a4c7ad38878596cd8b4246e44c5a3a35e5bc6452c02ebf35c9bed91970
diff --git a/media-sound/alsa-utils/alsa-utils-1.1.9.ebuild b/media-sound/alsa-utils/alsa-utils-1.1.9.ebuild
new file mode 100644
index 000000000000..bcc1f868e6d6
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.1.9.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="https://alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="bat doc +libsamplerate +ncurses nls selinux"
+
+CDEPEND=">=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7:0= )
+ bat? ( sci-libs/fftw:= )"
+DEPEND="${CDEPEND}
+ doc? ( app-text/xmlto )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-alsa )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.8-missing_header.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
+ --disable-alsaconf
+ --disable-maintainer-mode
+ --with-asound-state-dir="${EPREFIX}"/var/lib/alsa
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="${EPREFIX}/$(get_udevdir)"/rules.d
+ $(use_enable bat)
+ $(use_enable libsamplerate alsaloop)
+ $(use_enable ncurses alsamixer)
+ $(use_enable nls)
+ $(usex doc '' --disable-xmlto)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc seq/*/README.*
+
+ newinitd "${FILESDIR}"/alsasound.initd-r7 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+
+ # ALSA lib parser.c:1266:(uc_mgr_scan_master_configs) error: could not
+ # scan directory /usr/share/alsa/ucm: No such file or directory
+ # alsaucm: unable to obtain card list: No such file or directory
+ keepdir /usr/share/alsa/ucm
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}