summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-03-16 10:31:56 -0700
committerPatrick McLean <chutzpah@gentoo.org>2024-03-16 10:32:16 -0700
commit2cc780302cb92791bb3a23a30125dae21e742d78 (patch)
tree6aea217bbb1e8cde74b5a9a9f3204321e48cfbd8
parentnet-misc/freerdp: disable sample client (diff)
downloadgentoo-2cc780302cb92791bb3a23a30125dae21e742d78.tar.gz
gentoo-2cc780302cb92791bb3a23a30125dae21e742d78.tar.bz2
gentoo-2cc780302cb92791bb3a23a30125dae21e742d78.zip
sys-cluster/ceph: Add filter-lto (bug #927066)
Closes: https://bugs.gentoo.org/927066 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--sys-cluster/ceph/ceph-16.2.15.ebuild3
-rw-r--r--sys-cluster/ceph/ceph-17.2.6-r8.ebuild3
-rw-r--r--sys-cluster/ceph/ceph-17.2.7.ebuild3
-rw-r--r--sys-cluster/ceph/ceph-18.2.1.ebuild3
4 files changed, 12 insertions, 0 deletions
diff --git a/sys-cluster/ceph/ceph-16.2.15.ebuild b/sys-cluster/ceph/ceph-16.2.15.ebuild
index 0a7e20f913c0..b1cd72124475 100644
--- a/sys-cluster/ceph/ceph-16.2.15.ebuild
+++ b/sys-cluster/ceph/ceph-16.2.15.ebuild
@@ -362,6 +362,9 @@ ceph_src_configure() {
rm -f "${BUILD_DIR:-${S}}/CMakeCache.txt" \
|| die "failed to remove cmake cache"
+ # https://bugs.gentoo.org/927066
+ filter-lto
+
cmake_src_configure
# bug #630232
diff --git a/sys-cluster/ceph/ceph-17.2.6-r8.ebuild b/sys-cluster/ceph/ceph-17.2.6-r8.ebuild
index e9d12ff1cf46..ec78adf22305 100644
--- a/sys-cluster/ceph/ceph-17.2.6-r8.ebuild
+++ b/sys-cluster/ceph/ceph-17.2.6-r8.ebuild
@@ -382,6 +382,9 @@ ceph_src_configure() {
# hopefully this will not be necessary in the next release
use parquet && export ARROW_XSIMD_URL="file:///${DISTDIR}/ceph-xsimd-${PV}.tar.gz"
+ # https://bugs.gentoo.org/927066
+ filter-lto
+
cmake_src_configure
# bug #630232
diff --git a/sys-cluster/ceph/ceph-17.2.7.ebuild b/sys-cluster/ceph/ceph-17.2.7.ebuild
index ea040dd6b53a..8face2c0d114 100644
--- a/sys-cluster/ceph/ceph-17.2.7.ebuild
+++ b/sys-cluster/ceph/ceph-17.2.7.ebuild
@@ -384,6 +384,9 @@ ceph_src_configure() {
# hopefully this will not be necessary in the next release
use parquet && export ARROW_XSIMD_URL="file:///${DISTDIR}/ceph-xsimd-${PV}.tar.gz"
+ # https://bugs.gentoo.org/927066
+ filter-lto
+
cmake_src_configure
# bug #630232
diff --git a/sys-cluster/ceph/ceph-18.2.1.ebuild b/sys-cluster/ceph/ceph-18.2.1.ebuild
index e7b7cdfc84ec..38470ef0948a 100644
--- a/sys-cluster/ceph/ceph-18.2.1.ebuild
+++ b/sys-cluster/ceph/ceph-18.2.1.ebuild
@@ -380,6 +380,9 @@ ceph_src_configure() {
# hopefully this will not be necessary in the next release
use parquet && export ARROW_XSIMD_URL="file:///${DISTDIR}/ceph-xsimd-${PV}.tar.gz"
+ # https://bugs.gentoo.org/927066
+ filter-lto
+
cmake_src_configure
# bug #630232