summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-12-27 17:36:28 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-12-27 17:36:28 +0700
commit2ce2d5d166bc3f1fc49c988adf0e452d7ce1ffc9 (patch)
treed84c5cb74f1f449e5bf836c324a9ee4f4a21bc98
parentsci-mathematics/agda: set USE=-cpphs by default (diff)
downloadgentoo-2ce2d5d1.tar.gz
gentoo-2ce2d5d1.tar.bz2
gentoo-2ce2d5d1.zip
sci-geosciences/qmapshack: bump to 1.15.2
Closes: https://bugs.gentoo.org/761664 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--sci-geosciences/qmapshack/Manifest1
-rw-r--r--sci-geosciences/qmapshack/qmapshack-1.15.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-geosciences/qmapshack/Manifest b/sci-geosciences/qmapshack/Manifest
index 3ddd56bffe95..f699b4732866 100644
--- a/sci-geosciences/qmapshack/Manifest
+++ b/sci-geosciences/qmapshack/Manifest
@@ -1 +1,2 @@
DIST qmapshack-1.15.1.tar.gz 46265787 BLAKE2B b690d1e0ac698cee6969ef3cf35dd3b6102dd292993695fed81416a2bfe396e88bd8004b03a7eeb5df30c817331b83c55452f96200bd6c45145e86eb163ca988 SHA512 c01fc75fd6466a97e82b8f9822dfada87ededcec53e62a3dc42e36463c195ad4ba16c19a4748d48b26a0e957303f2724ec88eecb5d64676c74dbdaeebfadf17a
+DIST qmapshack-1.15.2.tar.gz 46899954 BLAKE2B b7121331039d8fedf6c44ef591e5f7a637787201bed1763bad026f866060d60a756f18858e76d95ea2420a3183f36147f2c72d151f377e8f2bc9108832266ff4 SHA512 536ba1c2fb3516560307c18eb76ef2b86fecaa1bc0fa4bcef25c8eb2e6c6dee5c3a9a81d6a9d05a147234df7c703937fd9e841696316c350694b0494705f885c
diff --git a/sci-geosciences/qmapshack/qmapshack-1.15.2.ebuild b/sci-geosciences/qmapshack/qmapshack-1.15.2.ebuild
new file mode 100644
index 000000000000..21da0a4f4d4a
--- /dev/null
+++ b/sci-geosciences/qmapshack/qmapshack-1.15.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+DESCRIPTION="GPS mapping utility"
+HOMEPAGE="https://github.com/Maproom/qmapshack/wiki"
+SRC_URI="https://github.com/Maproom/${PN}/archive/V_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/quazip
+ dev-qt/designer:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qthelp:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebengine:5[widgets]
+ >=sci-geosciences/routino-3.1.1
+ sci-libs/alglib
+ sci-libs/gdal
+ >=sci-libs/proj-6.0.0:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+S="${WORKDIR}"/${PN}-V_${PV}
+
+src_prepare() {
+ eapply FindPROJ4.patch
+ cmake_src_prepare
+ xdg_environment_reset
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}/html
+ cmake_src_install
+ mv "${D}"/usr/share/doc/HTML "${D}"/usr/share/doc/${PF}/html || die "mv Qt help failed"
+}