summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-08-05 14:44:48 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-08-05 14:49:52 -0500
commit2cf0f86e562c93b1626f8679f9b1a2621eb11405 (patch)
treed9bef5b0a6fa22c68b1dead8f9c7852c2d95037e
parentnet-vpn/networkmanager-openvpn: Version bump to 1.8.14 (diff)
downloadgentoo-2cf0f86e562c93b1626f8679f9b1a2621eb11405.tar.gz
gentoo-2cf0f86e562c93b1626f8679f9b1a2621eb11405.tar.bz2
gentoo-2cf0f86e562c93b1626f8679f9b1a2621eb11405.zip
app-emulation/docker-cli: 20.10.8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-emulation/docker-cli/Manifest1
-rw-r--r--app-emulation/docker-cli/docker-cli-20.10.8.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-emulation/docker-cli/Manifest b/app-emulation/docker-cli/Manifest
index cc17710a6c46..b0adbbe19646 100644
--- a/app-emulation/docker-cli/Manifest
+++ b/app-emulation/docker-cli/Manifest
@@ -1 +1,2 @@
DIST docker-cli-20.10.7.tar.gz 7523515 BLAKE2B 36ae46a28ca943e75419014b8b8453dbdd36bf240b9c36aed245447241dd07635da0319fd9b6ea409ecbe4c419eec8650d94d2a296e45a9c3b02a9a47a314888 SHA512 4523ae70cb27d848da119070171af2eb84e974ac39d70be4feee105e37c949487c7f72a9bc30c32ce71bffb0787e27b7b9194ce5a8aeae57bdfeb3f2d730010f
+DIST docker-cli-20.10.8.tar.gz 7526374 BLAKE2B 65b7733c9a71c7f266e83b7014ecdca998915e71352a1bbbb346be6a3a65f1ed6644b321b62d0592f2dbf308ff51d3d4ad0d9828831f5f90b451c6ff23452faa SHA512 60e9e623180d3cafd8bd6458d02574274871f94e88a0fa461e2200520717e837371a1b5d7fab6c9c4591e64807ab6f560e0756a9cfb1c1c8c9624b1f653346d0
diff --git a/app-emulation/docker-cli/docker-cli-20.10.8.ebuild b/app-emulation/docker-cli/docker-cli-20.10.8.ebuild
new file mode 100644
index 000000000000..d298b0daa2c0
--- /dev/null
+++ b/app-emulation/docker-cli/docker-cli-20.10.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GIT_COMMIT=3967b7d28e
+EGO_PN="github.com/docker/cli"
+MY_PV=${PV/_/-}
+inherit bash-completion-r1 golang-vcs-snapshot
+
+DESCRIPTION="the command line binary for docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="https://github.com/docker/cli/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="hardened"
+
+RDEPEND="!<app-emulation/docker-20.10.1"
+BDEPEND="
+ >=dev-lang/go-1.16.6
+ dev-go/go-md2man"
+
+RESTRICT="installsources strip"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+ default
+ sed -i 's@dockerd\?\.exe@@g' contrib/completion/bash/docker || die
+}
+
+src_compile() {
+ export DISABLE_WARN_OUTSIDE_CONTAINER=1
+ export GOPATH="${WORKDIR}/${P}"
+ # setup CFLAGS and LDFLAGS for separate build target
+ # see https://github.com/tianon/docker-overlay/pull/10
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ESYSROOT}/usr/$(get_libdir)"
+ emake \
+ LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
+ VERSION="$(cat VERSION)" \
+ GITCOMMIT="${GIT_COMMIT}" \
+ dynbinary
+
+ # build man pages
+ # see "cli/scripts/docs/generate-man.sh" (which also does "go get" for go-md2man)
+ mkdir -p ./man/man1 || die "mkdir failed"
+ go build -o "${T}"/gen-manpages ./man ||
+ die 'build gen-manpages failed'
+ "${T}"/gen-manpages --root "$(pwd)" --target "$(pwd)"/man/man1 ||
+ die 'gen-manpages failed'
+ ./man/md2man-all.sh -q ||
+ die 'md2man-all.sh failed'
+}
+
+src_install() {
+ dobin build/docker
+ doman man/man*/*
+ dobashcomp contrib/completion/bash/*
+ bashcomp_alias docker dockerd
+ insinto /usr/share/fish/vendor_completions.d/
+ doins contrib/completion/fish/docker.fish
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/_*
+}