summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-01-16 22:35:34 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-01-16 22:50:39 +0000
commit2cf547b0488752f4de600b0e9a82a70aa5584bf6 (patch)
tree63576bec716e31365e3d2bd87cc06303f1b8d890
parentx11-wm/xpra: Remove volnerable versions. (diff)
downloadgentoo-2cf547b0488752f4de600b0e9a82a70aa5584bf6.tar.gz
gentoo-2cf547b0488752f4de600b0e9a82a70aa5584bf6.tar.bz2
gentoo-2cf547b0488752f4de600b0e9a82a70aa5584bf6.zip
dev-util/include-what-you-use: set LLVM_MAX_SLOT=4 to use correct directory
Noticed by Michał Górny Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-4.0-r2.ebuild (renamed from dev-util/include-what-you-use/include-what-you-use-4.0-r1.ebuild)10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-util/include-what-you-use/include-what-you-use-4.0-r1.ebuild b/dev-util/include-what-you-use/include-what-you-use-4.0-r2.ebuild
index 5b23f35f1cb1..f278652a524e 100644
--- a/dev-util/include-what-you-use/include-what-you-use-4.0-r1.ebuild
+++ b/dev-util/include-what-you-use/include-what-you-use-4.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,8 +15,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="sys-devel/llvm:4
- sys-devel/clang:4
+LLVM_MAX_SLOT=4
+
+RDEPEND="sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-devel/clang:${LLVM_MAX_SLOT}
${PYTHON_DEPS}
"
DEPEND="${RDEPEND}"
@@ -46,7 +48,7 @@ src_configure() {
# 'clang' binary itself. See bug #625972
# Thus as a hack we install it to the same directory
# as llvm/clang itself.
- -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix)"
+ -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
)
cmake-utils_src_configure
}