summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-30 06:46:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-30 07:02:32 +0200
commit2cfd429af49f4d8fe177ac6d3f89cfbda4bfed3d (patch)
tree48833965fbe4119bfe8f5e44abdb3418e344c5bf
parentdev-python/sqlglot: Bump to 23.12.2 (diff)
downloadgentoo-2cfd429af49f4d8fe177ac6d3f89cfbda4bfed3d.tar.gz
gentoo-2cfd429af49f4d8fe177ac6d3f89cfbda4bfed3d.tar.bz2
gentoo-2cfd429af49f4d8fe177ac6d3f89cfbda4bfed3d.zip
dev-python/pyicu: Bump to 2.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyicu/Manifest1
-rw-r--r--dev-python/pyicu/pyicu-2.13.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pyicu/Manifest b/dev-python/pyicu/Manifest
index ab0f9b9a3bb6..e06d14bcd20a 100644
--- a/dev-python/pyicu/Manifest
+++ b/dev-python/pyicu/Manifest
@@ -1,2 +1,3 @@
DIST pyicu-v2.12.tar.bz2 195543 BLAKE2B ffee7f0d77495ca490047f6c1f280e47161a9dcebbf5525c8131a3876d10048f154aabfa2be98cd9bbe8e32cea2be86736cf7aa1b0193084b0b7dc36a45b861f SHA512 b182550a9491795699868908615a823e9e35220b6b43ef745a0e34563a133d2c9c2c5c8ae6e221f8c7117d310214828e8110f9e4113fd5cae7e724425de8fe84
+DIST pyicu-v2.13.1.tar.bz2 196960 BLAKE2B 8faf5faf1fb8246c07dfb5ace5c2ad7cf8c86a183e0fa48288c81f7de47422152af2a44392972d818542370ea6f91c592d8d520b49848389109e6b2c1aa3ee17 SHA512 f85dd31b6a505efd32c3d0ea1c996b51b9da8cdc7ce3b88c997573a4ef1506a6af7b76f48f86d64e8993878ae25abcd95b04f40ba7a4f38fbf3b4cefd79b8066
DIST pyicu-v2.13.tar.bz2 196895 BLAKE2B fba4b412eec92b4b108dc151450de0384324f43215a4ca2e502c91954a48b163b1b0cac290e77860288415be7cb86f2e2751e865636723d5c9481bae5a61410f SHA512 65ced1fe3040456fe7f0a37b67a5e3f2f7ed3fdfe3b1cce98b9dbba1e1f79a17df25c8370969087992964708958e2528d878ee913b3133cf1344866bc2444a9e
diff --git a/dev-python/pyicu/pyicu-2.13.1.ebuild b/dev-python/pyicu/pyicu-2.13.1.ebuild
new file mode 100644
index 000000000000..945d1e2c0dc1
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.13.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/
+"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+DEPEND="
+ dev-libs/icu:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test
+}