summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-14 06:06:00 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-14 07:11:02 +0100
commit2d0b3c7d0d9fd5a03c69d33cc97c2303eb0c1537 (patch)
tree952d3a1cf09e1baccff1284f9808bb6e5bc9a32b
parentwww-client/qutebrowser: add 2.5.4, drop 2.5.3-r1 (diff)
downloadgentoo-2d0b3c7d0d9fd5a03c69d33cc97c2303eb0c1537.tar.gz
gentoo-2d0b3c7d0d9fd5a03c69d33cc97c2303eb0c1537.tar.bz2
gentoo-2d0b3c7d0d9fd5a03c69d33cc97c2303eb0c1537.zip
dev-python/starlette: Bump to 0.26.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.26.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 4381775d51ae..cc9456858ad9 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1,3 +1,4 @@
DIST starlette-0.21.0.gh.tar.gz 2830353 BLAKE2B 7ff818d4687757ec8699dcd0e2582af78211787b7a0f2110da045eb4f7a8760262cf144b0af7dc9f72140b5dae1e65f7a4207ee3b165db4091c5139ce0bfcc85 SHA512 c246862604ba807141313857321d898d996eaa771ccb197546d0928a75cbb69f0e485fe90d2c817e70323146077c487436516384e1401d815c59c0ac75845e2b
DIST starlette-0.25.0.gh.tar.gz 2835696 BLAKE2B 82ed915a2ff7824a99e0f15f16a0723b8799ef43ab5b25dbbf7ee7bff7a3a1fc555e802a82950b11eb752a39e23fdf0870090a99bed568bfa82e3ecbcf42f5f3 SHA512 ecff4905c093ffd21a4b102d4ca1dba22ceebd8e73f53f984fbe58daa7a0bf9c3de9a41b1672837602142a4e14787f3b59291d05b9cb6a0dd034d58ddacd9eb1
DIST starlette-0.26.0.post1.gh.tar.gz 2837411 BLAKE2B b5db12f5c9fa8a8e9b78ec61ce26d2caff7f4160ad2e1446d6c161c223b3efc797e6cae65171e03aa14deb33172ceadb20d78ee02bd5754bc66e0406e4bbca89 SHA512 e8f1e98b922b2b067b1d7c581e5c9a6af887f204546ce04206abaea21b0c6e16de182022a5f70153a4f0833847f510f2ccae7f685c92a7f344a581d1d3d6ca0a
+DIST starlette-0.26.1.gh.tar.gz 2837634 BLAKE2B bfaef7cf0826cbb4ec133e47ae918a1021fd2fe1e7048651f72f6fdcba49a80ec53bff1d63cfa56cf9e075ea58f62db0a5fab4ccfd80463a69f79e26eabc8c03 SHA512 2974b778481f6a701e8697a7a48dad33cbb8569acc5e3bf123769c3f6380d6aa5730aff3e1ba4978eee025d2479e11c731b669e58e08e16f6870225ed813d42b
diff --git a/dev-python/starlette/starlette-0.26.1.ebuild b/dev-python/starlette/starlette-0.26.1.ebuild
new file mode 100644
index 000000000000..68330224a007
--- /dev/null
+++ b/dev-python/starlette/starlette-0.26.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/python-multipart[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.10.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest