summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-26 11:09:52 -0400
committerMatt Turner <mattst88@gentoo.org>2022-07-26 11:11:08 -0400
commit2d1465626a396e3f073629d5f2a6b53a33ce503d (patch)
tree4d5ddf71717c64e385f4e55660ac0d217462c7c7
parentapp-text/xpdf: drop 4.03 (diff)
downloadgentoo-2d1465626a396e3f073629d5f2a6b53a33ce503d.tar.gz
gentoo-2d1465626a396e3f073629d5f2a6b53a33ce503d.tar.bz2
gentoo-2d1465626a396e3f073629d5f2a6b53a33ce503d.zip
app-text/iso-codes: Version bump to 4.11.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-text/iso-codes/Manifest1
-rw-r--r--app-text/iso-codes/iso-codes-4.11.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index 87b00f2e6866..a5c9683a4bf2 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1 +1,2 @@
DIST iso-codes-v4.10.0.tar.gz 14624397 BLAKE2B a797db4cad381ae92bdeebf2b771059b5033a763dd1dc4ec85ac9eb81448482b20fc2c7293605816ad59ca6f5559221c72e22b6c0cd2c167af77b4f40dece4e3 SHA512 f77568fd803c32d8f28fc123c64c3122859f51c4c8f2f9cc4dc857e51d6fd6d1dfa42a4531f699b1f4b4b89adecb541a56e2cce0aac81ebf83f9c063dd79c86e
+DIST iso-codes-v4.11.0.tar.gz 14756251 BLAKE2B dd3bc5bae4def6338527a9c7c41f0ef9603eb2a2a7e4e2a95399bc4891a0d66fa323bb1f960263662cd6b4a42902defede64ad732f4a894d3073a7a68b5b9f80 SHA512 524be572c2505b0b2d55a7a0dd8d6bdff68edbc89c569652b11070cc6412881c98ea66a001193f1540153d44d6b41d921444a1d1a2bde6929bbe445eb369ea3e
diff --git a/app-text/iso-codes/iso-codes-4.11.0.ebuild b/app-text/iso-codes/iso-codes-4.11.0.ebuild
new file mode 100644
index 000000000000..b27a4c748d97
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-4.11.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PLOCALES="ab ace ach af ak am an ar as ast ay az ba bar be bg bi bn bn_BD bn_IN br bs byn ca ce ch chr ckb crh cs csb cv cy da de dv dz ee el en eo es et eu fa ff fi fil fo fr frp fur fy ga gez gl gn gu gv ha haw he hi hr ht hu hy ia id io is it iu ja jam ka kab ki kk kl km kmr kn ko kok kv kw ky lo lt lv mai mhr mi mk ml mn mo mr ms mt my na nah nb nb_NO ne nl nn nso nv oc or pa pap pi pl ps pt pt_BR ro ru rw sc sd si sk sl so son sq sr sr@latin sv sw ta te tg th ti tig tk tl tr tt tt@iqtelif tzm ug uk ur uz ve vi wa wal wo xh yo zh_CN zh_HK zh_Hans zh_Hant zh_TW zu"
+
+inherit python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="https://salsa.debian.org/iso-codes-team/iso-codes"
+SRC_URI="https://salsa.debian.org/${PN}-team/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+"
+S="${WORKDIR}/${PN}-v${PV}"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+DOCS=( CHANGELOG.md README.md )
+
+# plocale_find_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if has ${loc%.po} ${LINGUAS-${loc%.po}}; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}