summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-10-19 12:39:40 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-10-19 12:40:15 -0500
commit2d1ba039dbf40e3183bb16439ad62e589f9764a9 (patch)
tree05815f3f62bd96f272e36bfbd8e2edb7645833a1
parentdev-php/theseer-Autoload: Revbump to fix runtime errors of missing extensions (diff)
downloadgentoo-2d1ba039dbf40e3183bb16439ad62e589f9764a9.tar.gz
gentoo-2d1ba039dbf40e3183bb16439ad62e589f9764a9.tar.bz2
gentoo-2d1ba039dbf40e3183bb16439ad62e589f9764a9.zip
dev-vcs/python-gitlab: 2.10.1 bump
Closes: https://bugs.gentoo.org/818784 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/files/python-gitlab-2.10.1-do-not-package-tests.patch25
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-2.10.1.ebuild39
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index 1a2836092164..168103ba5ad8 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -1,2 +1,3 @@
+DIST python-gitlab-2.10.1.tar.gz 178899 BLAKE2B 5b0fd1552fca15827d9fa12745d035288c4796abbf3b7aeb9f9191a50800641ce0205f551724d8af9ed572b6ebc98052a2411f07b45c23a762fc1b9f713b3b31 SHA512 ab3ca0039ca5fa0b025ffbbe9ee65b1041d02c869f86e8656f6616d4e1dbc3d20898d5cfffcdf0557ad545c40837e4517bffefdbee9948fb366aba7e22d7eb41
DIST python-gitlab-2.5.0.tar.gz 148916 BLAKE2B f870833a01adac08b71dc402bc11ba9c1be19c920735faf04de9bfca3b1a154706da4bc0475437997e3b03d8c9a56977a6691df05b750d64a1f8b964ecd05612 SHA512 7382f9ea2388c6916f3c7e63df137d73f0fdfb3890a8bbb47e766f3476b6febecd1dcbc588445ae1af1b5f17c9a3e6ed9a931fd9fff010c2c37967eab5440824
DIST python-gitlab-2.6.0.tar.gz 153577 BLAKE2B 4fa0206faa601061fde257988362eca962c9e20f50e5ad57d602a76618581db646f26b035d4d86b9c460ef75f241fcbcdf360419b2e62ec6f95a664ab237d7d2 SHA512 b63dd4657b44fb484d114ceddc1d67465c17560978a8e6b09a9b14634ae6d80bf864b9b4583ddfc102c27c1082f4a015958c30944a734ec635761af524956fbe
diff --git a/dev-vcs/python-gitlab/files/python-gitlab-2.10.1-do-not-package-tests.patch b/dev-vcs/python-gitlab/files/python-gitlab-2.10.1-do-not-package-tests.patch
new file mode 100644
index 000000000000..f1f0c6ca8d3d
--- /dev/null
+++ b/dev-vcs/python-gitlab/files/python-gitlab-2.10.1-do-not-package-tests.patch
@@ -0,0 +1,25 @@
+From 969dccc084e833331fcd26c2a12ddaf448575ab4 Mon Sep 17 00:00:00 2001
+From: Nejc Habjan <hab.nejc@gmail.com>
+Date: Fri, 3 Sep 2021 00:28:18 +0200
+Subject: [PATCH] fix(build): do not package tests in wheel
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 6a05a72..589f9a4 100644
+--- a/setup.py
++++ b/setup.py
+@@ -24,7 +24,7 @@ setup(
+ author_email="gauvain@pocentek.net",
+ license="LGPLv3",
+ url="https://github.com/python-gitlab/python-gitlab",
+- packages=find_packages(),
++ packages=find_packages(exclude=["tests*"]),
+ install_requires=["requests>=2.25.0", "requests-toolbelt>=0.9.1"],
+ package_data={
+ "gitlab": ["py.typed"],
+--
+2.32.0
+
diff --git a/dev-vcs/python-gitlab/python-gitlab-2.10.1.ebuild b/dev-vcs/python-gitlab/python-gitlab-2.10.1.ebuild
new file mode 100644
index 000000000000..5067288cbfbf
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-2.10.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND=">=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${P}"-do-not-package-tests.patch
+)
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}