summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-10 11:52:13 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-10 11:53:21 +0200
commit2d1c978adbbe081b9831c091b55dc6fe90c73865 (patch)
tree3b46278877628931ef1755949d02b4b7dade0504
parentnet-misc/youtube-dl: Old (diff)
downloadgentoo-2d1c978a.tar.gz
gentoo-2d1c978a.tar.bz2
gentoo-2d1c978a.zip
net-misc/socat: Version 1.7.3.3
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-misc/socat/Manifest1
-rw-r--r--net-misc/socat/socat-1.7.3.3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/socat/Manifest b/net-misc/socat/Manifest
index 9de02486bea1..e45a2fb03852 100644
--- a/net-misc/socat/Manifest
+++ b/net-misc/socat/Manifest
@@ -1,2 +1,3 @@
DIST socat-1.7.3.2.tar.bz2 493324 BLAKE2B 8f30a47be52fcbaf9715435c7848e0d86bb8166fd7aa2de5ba2c7a297696ad1ebc6315acfb87fb8777f87645575fbc015c9e4b1a664fa6602bdf6cf2bc4481e5 SHA512 9ed4911deb09c36955b62a2efbcdfdff0e9d963fa30110e32396e49133d395afd7e61a19ca6a1a23e6e98ded4f603bcbb68c8eb3da4ce870f1450b8b6f7dd293
+DIST socat-1.7.3.3.tar.bz2 489901 BLAKE2B 5bd919dbef2efb64b4674ea072375d2b4e7c14629c2a48cd2f0233f31163c5aadd02f99d98a54b5f1375bbe7291d8134d4bb59d74a674d99d95714720b482cce SHA512 6073facb3db7cd24b9380f400876d73537b52b8e53ff6aac080388c2b1fc4a2decdfac7ce23bff6ab680fb2751251cda7fc67be9b09954edc46f449e0a7d0c7e
DIST socat-2.0.0-b9.tar.bz2 516673 BLAKE2B 808c8821b89ae2463074f87915dfae10f82b66ac6cd0b6ff56ab18f57c704e5a2a3ce76650152dccce41e4bd00e3a937948d4ade0a915b1f0e917c7543c6fc31 SHA512 f728bd634feeeacd2f0e4020c1c6aafdadaef3ba9da818d9ae1195e9f48fb693b2bea8dbbb208af8daddd8d6405217113d5ce31d05c2e9b27f5d2fba6b1cc834
diff --git a/net-misc/socat/socat-1.7.3.3.ebuild b/net-misc/socat/socat-1.7.3.3.ebuild
new file mode 100644
index 000000000000..5d48079d56cc
--- /dev/null
+++ b/net-misc/socat/socat-1.7.3.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="bindist libressl ssl readline ipv6 tcpd"
+
+DEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ readline? ( sys-libs/readline:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="
+ ${DEPEND}
+"
+RESTRICT="
+ test
+ ssl? ( readline? ( bindist ) )
+"
+DOCS=(
+ BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
+)
+
+pkg_setup() {
+ # bug #587740
+ if use readline && use ssl; then
+ elog "You are enabling both readline and openssl USE flags, the licenses"
+ elog "for these packages conflict. You may not be able to legally"
+ elog "redistribute the resulting binary."
+ fi
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ filter-flags '-Wno-error*' #293324
+ tc-export AR
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc doc/*.html doc/*.css
+}