summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-23 20:41:09 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-23 21:17:18 +0200
commit2d20544a8bbe0b4c552bc35387618484139dfbee (patch)
tree8823795399c952a8d291b84082e91656936da2fb
parentgames-arcade/pydance: Drop old (diff)
downloadgentoo-2d20544a.tar.gz
gentoo-2d20544a.tar.bz2
gentoo-2d20544a.zip
games-arcade/retrobattle: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch8
-rw-r--r--games-arcade/retrobattle/retrobattle-1.0.0-r1.ebuild36
2 files changed, 40 insertions, 4 deletions
diff --git a/games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch b/games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch
index 19974e36ea56..62af1f4718ef 100644
--- a/games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch
+++ b/games-arcade/retrobattle/files/retrobattle-1.0.0-gcc6.patch
@@ -1,5 +1,5 @@
---- a/src/GameLogic.h
-+++ b/src/GameLogic.h
+--- src/GameLogic.h
++++ src/GameLogic.h
@@ -52,8 +52,8 @@
/* Fixed interval time-based animation */
static const int maximumFrameRate = 60;
@@ -11,8 +11,8 @@
float lastFrameTime;
float cyclesLeftOver;
---- a/src/GameLogic.cc
-+++ b/src/GameLogic.cc
+--- src/GameLogic.cc
++++ src/GameLogic.cc
@@ -206,3 +206,6 @@
{
sprintf(buf, "%s/data/gfx/%s", datadir, file);
diff --git a/games-arcade/retrobattle/retrobattle-1.0.0-r1.ebuild b/games-arcade/retrobattle/retrobattle-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..411ae4f57017
--- /dev/null
+++ b/games-arcade/retrobattle/retrobattle-1.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="A NES-like platform arcade game"
+HOMEPAGE="http://remar.se/andreas/retrobattle/"
+SRC_URI="http://remar.se/andreas/retrobattle/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# test is incomplete
+RESTRICT="test"
+
+DEPEND="media-libs/libsdl[X,sound,video]
+ media-libs/sdl-mixer[wav]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/src"
+
+PATCHES=( "${FILESDIR}"/${P}-{build,sound,gcc6}.patch )
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r "${WORKDIR}"/${MY_P}/data
+
+ newbin "${WORKDIR}"/${MY_P}/${PN} ${PN}.bin
+ make_wrapper ${PN} "${PN}.bin \"/usr/share/${PN}\""
+
+ make_desktop_entry ${PN}
+ dodoc "${WORKDIR}"/${MY_P}/{manual.txt,README}
+}