summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-27 16:30:48 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-27 16:30:48 +0200
commit2d25811f80b28d70558fdfff1391a856fbffd47f (patch)
treefcb10bb9d0efdeb7c35be63d7487afc6cd07681b
parentwww-client/firefox: require sys-devel/llvm[gold] when USE=clang (diff)
downloadgentoo-2d25811f.tar.gz
gentoo-2d25811f.tar.bz2
gentoo-2d25811f.zip
www-client/firefox: clang doesn't support thumb-interwork
Bug: https://bugs.gentoo.org/666966 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
-rw-r--r--www-client/firefox/firefox-62.0.2.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-62.0.2.ebuild b/www-client/firefox/firefox-62.0.2.ebuild
index 5afa3158b7f7..68e3ed1ea93d 100644
--- a/www-client/firefox/firefox-62.0.2.ebuild
+++ b/www-client/firefox/firefox-62.0.2.ebuild
@@ -323,8 +323,12 @@ src_configure() {
# Modifications to better support ARM, bug 553364
if use neon ; then
mozconfig_annotate '' --with-fpu=neon
- mozconfig_annotate '' --with-thumb=yes
- mozconfig_annotate '' --with-thumb-interwork=no
+
+ if ! tc-is-clang ; then
+ # thumb options aren't supported when using clang, bug 666966
+ mozconfig_annotate '' --with-thumb=yes
+ mozconfig_annotate '' --with-thumb-interwork=no
+ fi
fi
if [[ ${CHOST} == armv* ]] ; then
mozconfig_annotate '' --with-float-abi=hard