summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-12-20 20:52:15 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-12-20 21:02:59 +0100
commit2d31c74f929dad89471fa02d043456934c01ee03 (patch)
treefb501f9e72f4e1979f08e6607ad7959de8c936b6
parentdev-python/nbconvert: add 7.2.7 (diff)
downloadgentoo-2d31c74f929dad89471fa02d043456934c01ee03.tar.gz
gentoo-2d31c74f929dad89471fa02d043456934c01ee03.tar.bz2
gentoo-2d31c74f929dad89471fa02d043456934c01ee03.zip
dev-python/nbformat: add 5.7.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/files/nbformat-5.7.1-no-node.patch27
-rw-r--r--dev-python/nbformat/nbformat-5.7.1.ebuild47
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index e50566c9192b..a6975294fa3b 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1 +1,2 @@
DIST nbformat-5.4.0.gh.tar.gz 134574 BLAKE2B f61275ad501381f05dc22a79f24c175fa71610f09cf125a40aaa90d0e02d3b27d82d918c1036b0516d4f879609f65c1ce62de86b033012e25d353af453828b2e SHA512 f601438193bfcb11f1ceed74995ab6862ff8c916f9bddabe38fd70bb997f4407bede4318ae7034d75424b20b75846010ddda2a45b8fe8de6dd9310617b00fb9d
+DIST nbformat-5.7.1.tar.gz 139291 BLAKE2B 680952ef35235021b36357babd98c94656d96888e1e5e01ecf35ce3233d51f751a60c964f0675fbad18242db8a1adb9fce2bbc512cefc4e30c254492584956c3 SHA512 248640ee23aae83c9c2b18502369d99c317447d40e5b3dc790260d21eda8ef027a7eca9ded34b98c7b17be7fe4b4401c556dbb9d4b0be80d4e4bff10a17381ce
diff --git a/dev-python/nbformat/files/nbformat-5.7.1-no-node.patch b/dev-python/nbformat/files/nbformat-5.7.1-no-node.patch
new file mode 100644
index 000000000000..e88cc8cdd522
--- /dev/null
+++ b/dev-python/nbformat/files/nbformat-5.7.1-no-node.patch
@@ -0,0 +1,27 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index e30d156..97e57de 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,10 +1,10 @@
+ [build-system]
+-requires = ["hatchling>=1.5", "hatch-nodejs-version"]
++requires = ["hatchling>=1.5"]
+ build-backend = "hatchling.build"
+
+ [project]
+ name = "nbformat"
+-dynamic = ["version"]
++version = "5.7.1"
+ description = "The Jupyter Notebook format"
+ license = { file = "COPYING.md" }
+ keywords = ["Interactive", "Interpreter", "Shell", "Web"]
+@@ -58,9 +58,6 @@ test = [
+ [project.scripts]
+ jupyter-trust = "nbformat.sign:TrustNotebookApp.launch_instance"
+
+-[tool.hatch.version]
+-source = "nodejs"
+-
+ [tool.hatch.envs.docs]
+ features = ["docs"]
+ [tool.hatch.envs.docs.scripts]
diff --git a/dev-python/nbformat/nbformat-5.7.1.ebuild b/dev-python/nbformat/nbformat-5.7.1.ebuild
new file mode 100644
index 000000000000..2aea4d3d8c3f
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.7.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbformat/
+ https://pypi.org/project/nbformat/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/numpydoc
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-node.patch"
+)
+
+EPYTEST_IGNORE=(
+ # requires pep440 package, which is not really relevant for us
+ tests/test_api.py
+)