summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-26 22:14:58 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-26 22:15:46 +0100
commit2d394b728c6354a5bf174d29bbf6905685f92eb5 (patch)
tree6a2f2ca38365ce23e1a51de6f1836b0dddcaf357
parentdev-python/bleach: Bump to 3.2.3 (diff)
downloadgentoo-2d394b728c6354a5bf174d29bbf6905685f92eb5.tar.gz
gentoo-2d394b728c6354a5bf174d29bbf6905685f92eb5.tar.bz2
gentoo-2d394b728c6354a5bf174d29bbf6905685f92eb5.zip
dev-python/smmap: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/smmap/Manifest1
-rw-r--r--dev-python/smmap/smmap-4.0.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/smmap/Manifest b/dev-python/smmap/Manifest
index 4a537cdf8fa8..449f8b29f42a 100644
--- a/dev-python/smmap/Manifest
+++ b/dev-python/smmap/Manifest
@@ -1,2 +1,3 @@
DIST smmap-3.0.4.tar.gz 22459 BLAKE2B daccd2cfa4d448297d1a0b2c33c1a316e8c84ae5dbe934d688fbdf034a660214c98d428206b8e9ce1cab3e5f3561309a1e7f29e3371b7358954f0fe7ea37092d SHA512 da7e5c0257f29b487eb5ee18f29656340f7f6999dd625d93560444d526df8036a8fc4452242a2d01203907798709d82a0015709e097bc22acd3d0a8b976ef9fe
DIST smmap-3.0.5.tar.gz 23228 BLAKE2B ccc36c33e9239f69a41eff291dcde7e455a84d886c2b087464b1b084ad8506b9d0f862b083635d51465089564edbd27ed0b7c9c5a0d1e58605b3db6f84dea857 SHA512 82d0167ba439164b5b9e6ca6081558b7f32af364f7935aa40500b34ca80e0fcf8d014e53eb2963e189d28ef18c8dd48da0b515392d149608fc3179fae3f69ee1
+DIST smmap-4.0.0.tar.gz 22524 BLAKE2B 2edd07925d9511879cb816f1e80d5fe7920ef91635f085b8d0ca81fa8d46bf0a1dfce7eab6f70250b93602a5a10e8170045f0720cf9fe3b26911d4e8b419f4cf SHA512 fae59fd4e8ccc95cbc07be3ece208e862948c2b537850376b169acc15b9f0b1d94d412fde88647c245dda117dbbdab4db6426e1d95f3f9779bdd40c2d9c7d2cd
diff --git a/dev-python/smmap/smmap-4.0.0.ebuild b/dev-python/smmap/smmap-4.0.0.ebuild
new file mode 100644
index 000000000000..64612c873ca5
--- /dev/null
+++ b/dev-python/smmap/smmap-4.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python implementation of a sliding window memory map manager"
+HOMEPAGE="
+ https://pypi.org/project/smmap/
+ https://github.com/gitpython-developers/smmap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+SLOT="0"
+
+distutils_enable_tests unittest