summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-19 18:25:51 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-20 08:40:31 -0400
commit2d39671b89942b0b8563ac9114355dc2b66e7445 (patch)
treeb7324c5b4776aac02b7b530f5234476b1cafa078
parentgames-action/barrage: add 1.0.5 (diff)
downloadgentoo-2d39671b89942b0b8563ac9114355dc2b66e7445.tar.gz
gentoo-2d39671b89942b0b8563ac9114355dc2b66e7445.tar.bz2
gentoo-2d39671b89942b0b8563ac9114355dc2b66e7445.zip
games-action/chromium-bsu: add 0.9.16.1
Adds SDL2 support, and migrated to EAPI-7. Also enable the otherwise silently disabled joystick support. Closes: https://bugs.gentoo.org/600342 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-action/chromium-bsu/Manifest1
-rw-r--r--games-action/chromium-bsu/chromium-bsu-0.9.16.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/games-action/chromium-bsu/Manifest b/games-action/chromium-bsu/Manifest
index 79d2960543b3..7cef0d1e2023 100644
--- a/games-action/chromium-bsu/Manifest
+++ b/games-action/chromium-bsu/Manifest
@@ -1 +1,2 @@
DIST chromium-bsu-0.9.15.1.tar.gz 1689634 BLAKE2B c834cb5b962031a1b8d187df9a58104896a53188907e5c3e7776aa129be3ff9287c6750af3f3df2a447b86f9f67f7dc5db21dca7d6f6cdaf2a8faad619723c75 SHA512 1e62161a10a5eb4246c0e04a13e7d8b521218aa709cced5bed1440055bb91bbcff45a85e544bdc6854f1ed727ea15257d34a3c988c65818bfbfe8004ac76c104
+DIST chromium-bsu-0.9.16.1.tar.gz 1709898 BLAKE2B b89ba20756fcb5903ed45c5174a0353618fb1bb1577ddb3f525d3f2a4242744e76297ca35fe186d36687d4d7f6bbe8de2a5dca8049697d5b82059e056fd16995 SHA512 1d202c0704e16b31d93c552ae6cfc17caf1182a9ec80730a981cd99c8ca8cb64d4e6e838691aa86e17ea23b7c2c0b1e7b1f4dab91bbc6129f9bf86801f2b27c8
diff --git a/games-action/chromium-bsu/chromium-bsu-0.9.16.1.ebuild b/games-action/chromium-bsu/chromium-bsu-0.9.16.1.ebuild
new file mode 100644
index 000000000000..2868bdfc3dd5
--- /dev/null
+++ b/games-action/chromium-bsu/chromium-bsu-0.9.16.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic xdg
+
+DESCRIPTION="Fast paced, arcade-style, top-scrolling space shooter"
+HOMEPAGE="http://chromium-bsu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/chromium-bsu/${P}.tar.gz"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openal"
+
+RDEPEND="
+ media-libs/libsdl2[joystick,opengl,video]
+ media-libs/quesoglc
+ media-libs/sdl2-image[png]
+ virtual/glu
+ virtual/libintl
+ virtual/opengl
+ openal? (
+ media-libs/freealut
+ media-libs/openal
+ )
+ !openal? (
+ media-libs/libsdl2[sound]
+ media-libs/sdl2-mixer
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+src_configure() {
+ append-cppflags -DWITH_JOYSTICK
+
+ local econfargs=(
+ $(use_enable openal)
+ --docdir="${EPREFIX}"/usr/share/${PF}/html
+
+ # there's other build-time alternatives but most are deprecated/dead
+ # or with some issues, simply stick to the newly added SDL2 support
+ --disable-{ftgl,glpng,glut,sdl,sdlimage,sdlmixer}
+ )
+ econf "${econfargs[@]}"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+}